summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-23 11:35:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-23 11:35:54 +0200
commit0a9700d7d7032e7bed4752932d432cd0096ae6b9 (patch)
treeac9bc8ef22355876fd0c0d6933833d460b259f9a
parentdev-vcs/ghp-import: Remove last-rited pkg (diff)
downloadgentoo-0a9700d7.tar.gz
gentoo-0a9700d7.tar.bz2
gentoo-0a9700d7.zip
dev-vcs/git-imerge: Remove last-rited pkg
Closes: https://bugs.gentoo.org/718308 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-vcs/git-imerge/Manifest1
-rw-r--r--dev-vcs/git-imerge/files/git-imerge.bashcomplete267
-rw-r--r--dev-vcs/git-imerge/git-imerge-1.0.0.ebuild45
-rw-r--r--dev-vcs/git-imerge/metadata.xml8
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 326 deletions
diff --git a/dev-vcs/git-imerge/Manifest b/dev-vcs/git-imerge/Manifest
deleted file mode 100644
index edbfa2819616..000000000000
--- a/dev-vcs/git-imerge/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST git-imerge-1.0.0.tar.gz 58736 BLAKE2B 16665436d10d07058eeadab5d53a2325d68174f6fcf1748948d0fc4fbe11ab4fca87853bb557e167b0f485351aedd72889fcedaa70f09439d7e66b75a61d318b SHA512 919b80f157d635e3a3eb2b05cfaf8f6a7034fe6f43529c829fef0152007bce3bf5b296cc00f6db0c0a711bfb9e118c4adb0f5a2641ff841c973ff12610473e9b
diff --git a/dev-vcs/git-imerge/files/git-imerge.bashcomplete b/dev-vcs/git-imerge/files/git-imerge.bashcomplete
deleted file mode 100644
index 0fe8e04f64de..000000000000
--- a/dev-vcs/git-imerge/files/git-imerge.bashcomplete
+++ /dev/null
@@ -1,267 +0,0 @@
-__git_imerge_branches () {
- git for-each-ref --format='%(refname)' refs/heads/ refs/remotes/ 2>/dev/null |
- sed -e 's!^refs/heads/!!' -e 's!^refs/remotes/!!'
-}
-
-__git_imerge_names () {
- git for-each-ref --format='%(refname)' refs/imerge/ 2>/dev/null |
- sed -e 's/^refs\/imerge\/\(.*\)\/.*/\1/' -e '/manual/d' -e '/auto/d'
-}
-
-__git_imerge_goals="\
-merge
-rebase
-rebase-with-history
-full
-"
-
-__git_imerge_commands="\
-start
-merge
-rebase
-continue
-finish
-diagram
-list
-init
-record
-autofill
-simplify
-remove
-reparent
-"
-
-__git_imerge_start_options="\
---help
---manual
---name
---branch
---goal
---first-parent
-"
-
-__git_imerge_init_options=$__git_imerge_start_options
-
-__git_imerge_continue_options="\
---help
---name
---edit
---no-edit
-"
-
-__git_imerge_finish_options="\
---help
---name
---goal
---branch
---force
-"
-
-__git_imerge_simplify_options=$__git_imerge_finish_options
-
-__git_imerge_merge_options="\
---help
---name
---goal
---branch
---manual
-"
-
-__git_imerge_list_options="\
---help
-"
-
-__git_imerge_reparent_options=$__git_imerge_list_options
-
-__git_imerge_record_options="\
---help
---name
---edit
---no-edit
-"
-
-__git_imerge_autofill_options="\
---help
---name
-"
-
-__git_imerge_diagram_options="\
---help
---name
---commits
---frontier
---html
---color
---no-color
-"
-
-__git_imerge_remove_options=$__git_imerge_autofill_options
-
-__git_imerge_rebase_options=$__git_imerge_merge_options
-
-__git-imerge_start_completion() {
- case "$1_$cur" in
- --help_|--branch_|_--branch=|--name_|_--name=)
- return
- ;;
- --goal_*|*_--goal=*)
- __gitcomp "$__git_imerge_goals" "" "${cur##--goal=}"
- return
- ;;
- *-|*_-*?)
- __gitcomp "$__git_imerge_start_options"
- return
- ;;
- esac
- __gitcomp "$(__git_imerge_branches)"
-}
-
-__git-imerge_init_completion() {
- __git-imerge_start_completion $1
-}
-
-__git-imerge_continue_completion() {
- case "$1_$cur" in
- --help_)
- return
- ;;
- --name_*|*_--name=*)
- __gitcomp "$(__git_imerge_names)" "" "${cur##--name=}"
- return
- ;;
- esac
- __gitcomp "$__git_imerge_continue_options"
-}
-
-__git-imerge_finish_completion() {
- case "$1_$cur" in
- --help_)
- return
- ;;
- --goal_*|*_--goal=*)
- __gitcomp "$__git_imerge_goals" "" "${cur##--goal=}"
- return
- ;;
- --branch_*|*_--branch=*)
- __gitcomp "$(__git_imerge_branches)" "" "${cur##--branch=}"
- return
- ;;
- --name_*|*_--name=*)
- __gitcomp "$(__git_imerge_names)" "" "${cur##--name=}"
- return
- ;;
- esac
- __gitcomp "$__git_imerge_finish_options"
-}
-
-__git-imerge_simplify_completion() {
- __git-imerge_finish_completion $1
-}
-
-__git-imerge_merge_completion() {
- case "$1_$cur" in
- --help_|--branch_|_--branch=|--name_|_--name=)
- return
- ;;
- --goal_*|*_--goal=*)
- __gitcomp "$__git_imerge_goals" "" "${cur##--goal=}"
- return
- ;;
- *-|*_-*?)
- __gitcomp "$__git_imerge_merge_options"
- return
- ;;
- esac
- __gitcomp "$(__git_imerge_branches)"
-}
-
-__git-imerge_rebase_completion() {
- __git-imerge_merge_completion $1
-}
-
-__git-imerge_list_completion() {
- case "$1" in
- --help)
- return
- ;;
- esac
- __gitcomp "$__git_imerge_list_options"
-}
-
-__git-imerge_reparent_completion() {
- __git-imerge_list_completion $1
-}
-
-__git-imerge_record_completion() {
- case "$1_$cur" in
- --help_)
- return
- ;;
- --name_*|*_--name=*)
- __gitcomp "$(__git_imerge_names)" "" "${cur##--name=}"
- return
- ;;
- esac
- __gitcomp "$__git_imerge_record_options"
-}
-
-__git-imerge_autofill_completion() {
- case "$1_$cur" in
- --help_)
- return
- ;;
- --name_*|*_--name=*)
- __gitcomp "$(__git_imerge_names)" "" "${cur##--name=}"
- return
- ;;
- esac
- __gitcomp "$__git_imerge_autofill_options"
-}
-
-__git-imerge_remove_completion() {
- __git-imerge_autofill_completion $1
-}
-
-__git-imerge_diagram_completion() {
- case "$1_$cur" in
- --help_|--html_|_--html=)
- return
- ;;
- --name_*|*_--name=*)
- __gitcomp "$(__git_imerge_names)" "" "${cur##--name=}"
- return
- ;;
- esac
- __gitcomp "$__git_imerge_diagram_options"
-}
-
-_git_imerge () {
- # Disable default filename completion. Note that "compopt" is only
- # available in Bash 4 and newer, so we check for existence before
- # trying to use it.
- type compopt >/dev/null 2>&1 && compopt +o default +o bashdefault
-
- local i command cur_opt
- for ((i=0; i <= ${cword}; i++)); do
- if [ -n "$command" ] && [ "${words[i]}" != "$cur" ]; then
- cur_opt="${words[i]}"
- fi
- if [ -z "$command" ] && \
- [ "$i" -lt "${cword}" ] && \
- [[ "${words[i-1]}" == *"imerge"* ]]
- then
- command="${words[i]}"
- fi
- done
-
- if test -z "$command"; then
- __gitcomp "$__git_imerge_commands"
- return
- fi
-
- if [ -z `type -t __git-imerge_"$command"_completion "$cur_opt"` ]; then
- return
- fi
-
- __git-imerge_"$command"_completion "$cur_opt"
-}
diff --git a/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild b/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
deleted file mode 100644
index 424d661ab002..000000000000
--- a/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 python-r1
-
-DESCRIPTION="Incremental merge for git"
-HOMEPAGE="https://github.com/mhagger/git-imerge"
-SRC_URI="https://github.com/mhagger/git-imerge/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-vcs/git"
-DEPEND="dev-python/docutils"
-
-src_compile() {
- for doc in *.rst; do
- rst2html.py "${doc}" > "${T}/${doc/.rst/.html}" \
- || die "failed to convert ${doc} to ${T}/${doc/.rst/.html}"
- done
-
- rst2s5.py \
- --theme=small-white \
- --current-slide \
- doc/presentations/GitMerge-2013/talk.rst \
- "${T}/talk.html" \
- || die 'failed to convert talk.rst to ${T}/talk.html'
-}
-
-src_install() {
- python_foreach_impl python_doscript "${PN}"
- newbashcomp "${FILESDIR}/git-imerge.bashcomplete" git-imerge
- dodoc *.rst "${T}"/*.html
-
- # Don't forget the CSS for the presentation.
- dodoc -r "${T}/ui"
-}
diff --git a/dev-vcs/git-imerge/metadata.xml b/dev-vcs/git-imerge/metadata.xml
deleted file mode 100644
index 33aa1137112c..000000000000
--- a/dev-vcs/git-imerge/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">mhagger/git-imerge</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index af3180f6cdb4..2dbcc279557b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -577,11 +577,6 @@ media-sound/beets
# Removal in 30 days. Bug #718340.
media-gfx/qrencode-python
-# Michał Górny <mgorny@gentoo.org> (2020-04-19)
-# Unmaintained. Stuck on Python 3.6.
-# Removal in 30 days. Bug #718308.
-dev-vcs/git-imerge
-
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-04-18)
# Unmaintained, vulnerable oracle java ebuilds, even fetching distfiles
# requires agreement to restrictive license