summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 19:53:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-29 00:17:53 -0400
commit0ab1846b289cd3a7c35cb206a5ae80609bf8ede0 (patch)
treecabb9a8b3207496fed28c5518e5a11530099b158
parentnet-im/element-desktop-bin: upgrade 1.11.1 -> 1.11.8 (diff)
downloadgentoo-0ab1846b.tar.gz
gentoo-0ab1846b.tar.bz2
gentoo-0ab1846b.zip
app-benchmarks/bonnie: EAPI6->8, use https, tidy patches
Also drop the Makefile patch, no reason to even use the Makefile. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild (renamed from app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild)19
-rw-r--r--app-benchmarks/bonnie/files/Makefile.patch16
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch10
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch8
-rw-r--r--app-benchmarks/bonnie/files/bonnie_man.patch16
5 files changed, 20 insertions, 49 deletions
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
index 9c683b9e65ac..6627f2b54a47 100644
--- a/app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild
+++ b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
-HOMEPAGE="http://www.textuality.com/bonnie/"
-SRC_URI="http://www.textuality.com/bonnie/bonnie.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://www.textuality.com/bonnie/"
+SRC_URI="https://www.textuality.com/bonnie/bonnie.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
LICENSE="bonnie"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-S=${WORKDIR}
PATCHES=(
- "${FILESDIR}"/bonnie_man.patch
- "${FILESDIR}"/Makefile.patch
"${FILESDIR}"/${P}-includes.patch
+ "${FILESDIR}"/${P}-man.patch
)
-src_configure() {
+src_compile() {
tc-export CC
+
+ emake -f /dev/null Bonnie
}
src_install() {
diff --git a/app-benchmarks/bonnie/files/Makefile.patch b/app-benchmarks/bonnie/files/Makefile.patch
deleted file mode 100644
index d803bd077ced..000000000000
--- a/app-benchmarks/bonnie/files/Makefile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,11 +1,9 @@
--CFLAGS = -O $(SYSFLAGS)
--
- bsd:
- @echo 'Options are "make bsd" and "make SysV" - the default is "bsd".'
- @echo 'If you get messages about missing functions, try "make SysV."'
-- make Bonnie
-+ $(MAKE) Bonnie
-
- SysV:
-- make Bonnie 'SYSFLAGS=-DSysV'
-+ $(MAKE) Bonnie 'SYSFLAGS=-DSysV'
-
- Bonnie:
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
index cfefe953c6f1..8bec1e2ab04d 100644
--- a/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
@@ -1,13 +1,9 @@
---- a/Bonnie.c 1996-08-28 18:23:49.000000000 +0200
-+++ b/Bonnie.c 2010-10-12 20:15:26.000000000 +0200
-@@ -29,6 +29,10 @@
- #include <fcntl.h>
- #include <sys/types.h>
+--- a/Bonnie.c
++++ b/Bonnie.c
+@@ -31,2 +31,6 @@
#include <sys/time.h>
+#include <time.h>
+#include <string.h>
+#include <stdlib.h>
+#include <sys/wait.h>
#if defined(SysV)
- #include <limits.h>
- #include <sys/times.h>
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch
new file mode 100644
index 000000000000..d492ebd7c922
--- /dev/null
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch
@@ -0,0 +1,8 @@
+--- a/bonnie.1
++++ b/bonnie.1
+@@ -63 +63 @@
+-.TH Bonnie 1 "2.0.6" Textuality
++.TH bonnie 1 "2.0.6" Textuality
+@@ -67 +67 @@
+-.B Bonnie
++.B bonnie
diff --git a/app-benchmarks/bonnie/files/bonnie_man.patch b/app-benchmarks/bonnie/files/bonnie_man.patch
deleted file mode 100644
index e4b2fe0a12e3..000000000000
--- a/app-benchmarks/bonnie/files/bonnie_man.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/bonnie.1 2003-01-07 14:19:29.000000000 -0600
-+++ b/bonnie.1 2003-01-07 14:20:19.000000000 -0600
-@@ -60,11 +60,11 @@
- .fi
- .in
- ..
--.TH Bonnie 1 "2.0.6" Textuality
-+.TH bonnie 1 "2.0.6" Textuality
- .SH NAME
- Bonnie - File system benchmark
- .SH "SYNOPSIS"
--.B Bonnie
-+.B bonnie
- .RI "[-d\ scratch-dir]"
- .RI "[-html]"
- .RI "[-m\ machine-label]"