summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-18 01:19:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-18 01:20:10 +0200
commit0ab5cf98272bf19ac0db628b584b0b77dffa8dbc (patch)
tree9a2dad9de62c729bc5d85be10b2e68ee8b835502
parentsys-block/vblade: bump to v25 (diff)
downloadgentoo-0ab5cf98.tar.gz
gentoo-0ab5cf98.tar.bz2
gentoo-0ab5cf98.zip
dev-php/PHPMailer: bump to v6.5.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.5.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index c77b6029bfd7..de4c646f8b9a 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1 +1,2 @@
DIST PHPMailer-6.4.1.tar.gz 98058 BLAKE2B 88b11e096be6a81591b2c68efb1fdc9a5ff0c384508939545c333f940a60949acb34db000ccd3ae9dbc4c5609f6d20006b7d08ad61bb96edf1d7f11b8091c236 SHA512 c702e53afec4a4c9cdb8757928883fcfd6ed5f2babc03466ca2a698e4e4535014407be5618e6dbcd69135f36f6f723fdee266f70fa6546563949d785f5db4f51
+DIST PHPMailer-6.5.0.tar.gz 99073 BLAKE2B dcb917233da29ab45305f7cf0405f9bb384bd4f98f062a74d94a168868d0cd92017e555bf8e7139130dd669e0a04917e3789c548b5165112d591aa403bfd56b8 SHA512 0632ec8b80c30393b00aebbadde7dd032eb2553232a100a74d69b6ed6465adf1eb3a4acca0aaf040665a978e7507aee9350b092336056ccb5306fbaea4640376
diff --git a/dev-php/PHPMailer/PHPMailer-6.5.0.ebuild b/dev-php/PHPMailer/PHPMailer-6.5.0.ebuild
new file mode 100644
index 000000000000..48dc349297f3
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.5.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ default
+
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}