summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Lunev <cheembox573@gmail.com>2023-11-25 15:12:28 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-11-26 09:02:38 +0200
commit0abb5770f29ec29021747dbd2c161d8d50154d39 (patch)
tree7db4311c42646671508770835e011dff425dca71
parentsys-fs/duperemove: Bump to 0.14.1 (diff)
downloadgentoo-0abb5770f29ec29021747dbd2c161d8d50154d39.tar.gz
gentoo-0abb5770f29ec29021747dbd2c161d8d50154d39.tar.bz2
gentoo-0abb5770f29ec29021747dbd2c161d8d50154d39.zip
net-p2p/qbittorrent: add 4.6.1
Closes: https://bugs.gentoo.org/916447 Signed-off-by: Alexey Lunev <cheembox573@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33978 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.6.1.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index ee5526699755..b73321d9d11c 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-4.5.2.tar.gz 8890525 BLAKE2B 48585b703ce6edf862ea3c8cfad6cab2ed
DIST qbittorrent-4.5.4.tar.gz 8791236 BLAKE2B 70b3194d6c4819655998406e0a13d22f3a5068e724048010daebd83d8b8db9e17daee943ca8dabaacd92a0fbc5249257de6d175b35287c748dc2d15395bd71fc SHA512 2e7988922137c9fade99e90236cc0c5b8b30f09021472f8ffc9048a7a2d989925eed7bfab4d79c93ca7d0f21acfde2e7feee5e6c43b557bf2c6f472fd52fbcea
DIST qbittorrent-4.5.5.tar.gz 8802492 BLAKE2B 1d20d7900b5b65603c5cf13452fb5aebe396473290d4904641b78867c5345d783482c46edc7042a2e86e79afd790e8c470df62131595eba288f195cc5e716eec SHA512 8b5c2654b3bc03c0b4de77e8388ee543c3892ef9453749ea737aaee999a16d50bd1b30ebe0519a86d7ab8ffc6224d7d9cf678464aebf96433cd71dd57b46dd53
DIST qbittorrent-4.6.0.tar.gz 9024538 BLAKE2B 5addeee21c9a5f05ca4b33a908c6480948dd22cc03524baf8f06429c2f1abb3c88115a53d434023e379561dda27ae43336068071c7f92949c550f6f8b4336a87 SHA512 217b3efe9c8e98eb5c9457d9aede91034b27f85a57ff93d57f51485b5224e85c63b51645b3f5126a51e48894d5065ed2ae3929dcabfcbbe6b036270286ffef3a
+DIST qbittorrent-4.6.1.tar.gz 9054911 BLAKE2B ace2f102f21287d7005fdd383bd44bed17894ad370ec7782684669f07c537e0c773acc90e89105794c02c023a4116dbe00fc99ba4ffae49c18159854baca9e5d SHA512 ed6db8174562cd2b96fec1e0c1532a65507cb7034841c9424f654a33866cbf9edc5974f101f0c01cd6c8fd7d76380b4252c4a804ee9776b34ec8ad1b386bdcd1
diff --git a/net-p2p/qbittorrent/qbittorrent-4.6.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.6.1.ebuild
new file mode 100644
index 000000000000..af2d2004687f
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.6.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake edo multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/qBittorrent-release-${PV}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui qt6 systemd test webui"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( gui webui )"
+
+RDEPEND="
+ acct-group/qbittorrent
+ acct-user/qbittorrent
+ >=dev-libs/openssl-1.1.1:=
+ >=net-libs/libtorrent-rasterbar-1.2.18:=
+ >=sys-libs/zlib-1.2.11
+ qt6? ( dev-qt/qtbase:6[network,ssl,sql,sqlite,xml] )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtxml:5
+ )
+ gui? (
+ !qt6? (
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dbus? ( dev-qt/qtdbus:5 )
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus?,gui,widgets]
+ dev-qt/qtsvg:6
+ )
+ )"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+ test? (
+ !qt6? ( dev-qt/qttest:5 )
+ qt6? ( dev-qt/qtbase:6[test] )
+ )"
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+ -DQT6=$(usex qt6)
+ -DWEBUI=$(usex webui)
+ -DTESTING=$(usex test)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == "gui" ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ my_src_test() {
+ cd "${BUILD_DIR}"/test || die
+ edo ctest .
+ }
+
+ multibuild_foreach_variant my_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+}