summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2018-10-25 19:20:16 +0100
committerIan Whyman <thev00d00@gentoo.org>2018-10-25 19:20:39 +0100
commit0ac0619b75f7f247396ce7db3964ebdbc30386ef (patch)
tree1a6b1340f0a0b8143a3efe334ecb75ee844f894a
parentdev-perl/MP3-Info: added Prefix keywords, bug #665088 (diff)
downloadgentoo-0ac0619b.tar.gz
gentoo-0ac0619b.tar.bz2
gentoo-0ac0619b.zip
net-libs/libupnp: 1.8.4 bump
Signed-off-by: Ian Whyman <thev00d00@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.8.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 0c688693ca64..ccbe5c129a3a 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -2,3 +2,4 @@ DIST libupnp-1.6.21.tar.bz2 1245353 BLAKE2B ca9ff07f88cfc77c3e3f7250ec1de6fb8c1a
DIST libupnp-1.6.25.tar.bz2 722731 BLAKE2B 7f1850a235683ecd19bc377cd5c80c9d7ee8f0ded123dfc00d29551d2fd97fb873ce4c30ce0d26d562c57470c266a573c37fed4c0db159c65c56c673271adf92 SHA512 c1426c2f855f34a56b96761602a35989867918b556ecf9784c9ce9580f6c6083950004909831bad331f3a4dfb70ef1bd287e026c71bbfde2613f77fe05ab9e1f
DIST libupnp-1.8.2.tar.gz 1379953 BLAKE2B 472851bfd25530ead4c113657f0e30cf7a3a1a4c88b86864676a2b7096817c1780718710a9535068904901c21d70d92fb267f295e88531e3eeef7d9a0cee58f3 SHA512 026f2568a1ffa56a3a0ebc823b126dceabb7e821acb6db52fbca02c4c02febd5508cb644cd2ac51f65397c3248a22340b3673069951e97dcdd22d4cc321d4511
DIST libupnp-1.8.3.tar.gz 1382278 BLAKE2B 65774d46633d81fcc810f01339e0eac5d7c7313f69c1a467e6c0bbb26eeee03fdb4d8330f46e86346737cc17c1c953ef26045526bc9fe438f7e917928a3a3d0e SHA512 592a719614492ee1dad3630e5de2dca1dbe369faa3c87ba20fb939334c9d24f9dc869a457f5903cd28c5f7662145d1db4eeb512ee93b47adad4fc9b7d9171507
+DIST libupnp-1.8.4.tar.gz 783896 BLAKE2B 483ae5344b0677441a02d4666476090e00d0f7b7798e24a7dbe7ea10cd68f02644851ba17cff06033714dc9f2ddf7d9c5588e5a54693f14ad1a9782a7751480d SHA512 6d96dc0dcf187a425f3b60f4e750102331bd0a5bd452007e345eeacb63e9287ac213574c8071294809283ff8d8795433706ed2a14bae3d451605bf7a75e5a5bb
diff --git a/net-libs/libupnp/libupnp-1.8.4.ebuild b/net-libs/libupnp/libupnp-1.8.4.ebuild
new file mode 100644
index 000000000000..a1fc1c7d0280
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.8.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install () {
+ default
+
+ use static-libs || prune_libtool_files
+
+ # Slot samples
+ if $(use samples); then
+ for bin in combo ctrlpt device ; do
+ newbin "upnp/sample/.libs/tv_$bin" "tv_$bin-${SLOT}"
+ done
+ fi
+
+ # Slot includes
+ cd "${D}/usr/include" || die
+ mv upnp "upnp-${SLOT}" || die
+
+ # Slot pkgconfig
+ cd "${D}/usr/$(get_libdir)/pkgconfig" || die
+ mv libupnp.pc "libupnp-${SLOT}.pc" || die
+ sed -i -e "s#/upnp#/upnp-${SLOT}#" \
+ -e "s#lupnp#lupnp-${SLOT}#" \
+ -e "s#lixml#lixml-${SLOT}#" "libupnp-${SLOT}.pc" || die
+
+ # Slot symlinks
+ cd "${D}/usr/$(get_libdir)" || die
+ mv libupnp.so "libupnp-${SLOT}.so" || die
+ mv libixml.so "libixml-${SLOT}.so" || die
+}