summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-18 21:11:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 21:11:39 +0300
commit0ad98bf29f1696fd403c4c05fcbebe1be36f38d3 (patch)
tree6de5274ab2523e144c95b97f6710b1894ca5d936
parentdev-python/setuptools: add 65.1.0 (diff)
downloadgentoo-0ad98bf2.tar.gz
gentoo-0ad98bf2.tar.bz2
gentoo-0ad98bf2.zip
dev-python/ensurepip-setuptools: add 65.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-65.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index c86590636a50..deb7cbedb88f 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1 +1,2 @@
DIST setuptools-65.0.2-py3-none-any.whl 1233332 BLAKE2B 0c0d0db73452d15947097f3d453f01bb42ef150b50122b7a1f39212f663064284bc313a04c3dbe99e8da7e614d72a963d6c9f0c8f486f5d84131a06718b288c8 SHA512 11d9975468166bf7db9a9da44d893a67daacc5f309da1b521278a95a33fa2b3574cae10840c9943de54bf5d411e54697f91b62a3bfb5a6a3bc69b804af2a1365
+DIST setuptools-65.1.0-py3-none-any.whl 1232689 BLAKE2B db8f85b99b1d47af55d484d77ecafe5122abe9ab8dcec565659bb91c16aa26513c00d8684ca3b7b57e629d512b42273188a00ee0a0958bba5097ce150869609f SHA512 1072a826964ec3413c5bcd3f930a2f314b87b0b77714ddc948573841fbb871a898843211beaff0bcc5e003fcaab678de5d2b9a3a9fa864beced1bf2af282d048
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.1.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.1.0.ebuild
new file mode 100644
index 000000000000..96c75c915768
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}