summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 08:53:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 09:56:24 +0200
commit0ada07e5d8ed5710bf894583a873a4e334378366 (patch)
treee24e9eaf3c81845f53c09b38c17e92d68b3f6112
parentdev-python/pylint: Bump to 2.8.0 (diff)
downloadgentoo-0ada07e5.tar.gz
gentoo-0ada07e5.tar.bz2
gentoo-0ada07e5.zip
dev-python/astroid: Bump to 2.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.5.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 7feb84f3e7f2..d461d268052f 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,4 +1,5 @@
DIST astroid-2.5.1.tar.gz 312511 BLAKE2B 85d85c045579f6bf42a4640da95836e760d1d89edaefdf94209a2fdc7f2686a27abcb1c0710cad658473a0a1516df5ad80f10c6b7c2a4f14dea36af94aa9ae5b SHA512 a0aaa95257961235abbbbc021cdb48da760f8b1856bbc0a7a8b98c53c69045cee4bfe575182a631f994765819e373b33b3a6eca052573128e8b36f2c23c250de
DIST astroid-2.5.2.tar.gz 312789 BLAKE2B 53b286a8772fea1df149aff19f56c0d86154e616a04f4e3e459e029bd4ae54e7f41c55873e0c310c4e36b0901a39bf88d92a7748a7a46baa000f386a0d154c05 SHA512 391d6b0981b4332fd074a568d33838cbd5d71e7200a3a7ba27bc96641d12be4a6452def0bb615a54e1fa6d1f1f6863a39d56cf3e503aba42ea0d0fdddbbb9102
DIST astroid-2.5.3.tar.gz 317721 BLAKE2B 66566287fa65489064056d6dba65fd7c59cbe9e4e3d88ba5a33d08dbcf6af48b6f1eb4aafb4f7483a1fc0eb6fdd92a7bc8f1991d05cd4d589fbcc6ed6f5db769 SHA512 dbf480e86023f7d093386cc68b259d5b721717638927a893b3ade0a397b212f5f24a17c753b705cf499b47e12ab255d51126b41b5af167d5c3018f5aade1abcb
+DIST astroid-2.5.5.tar.gz 181533 BLAKE2B 22b9a951ebdbfb75837ba80c29ab5d7b8ff0f7da49dad81465d4cc55a3fc5fa5c0c6383b59c59dc9fd4ef966d934f1894befe59eaa910822e6bd7fd1411a638f SHA512 0ecc77549e95f799af7a4b3902485feb6e04648123d3916cb6363272e7f2d1eef2fef122f0e08aae16ba8c4e86f17421a9bc805e0967e48e4df13cfb865df9c6
DIST astroid-2.5.tar.gz 304788 BLAKE2B 3d9304dcfff72aa8172fe88b5ee53b723b47b3e602b7c30cae15a61d0cff7d578ccfde4885b56c09c8254ca3fe185fcf297bf85184d68798eb51f1860c516db6 SHA512 eba7e757a12f89a74bff579731a157fda3c8d8dd1b5a4369791d47f7f6e321b23e167260d0988d389428222c8c98929e66ad26f379ff937e274dcd1abdb3b3d2
diff --git a/dev-python/astroid/astroid-2.5.5.ebuild b/dev-python/astroid/astroid-2.5.5.ebuild
new file mode 100644
index 000000000000..2c3e9125dba9
--- /dev/null
+++ b/dev-python/astroid/astroid-2.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ --deselect
+ tests/unittest_modutils.py::GetModulePartTest::test_knownValues_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker "${deselect[@]}"
+}