summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-29 22:52:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-29 23:28:50 +0100
commit0b0ba372520d58dc1d3c7a1fef55c1800c7be3dc (patch)
treeda9a6f400301c1198bdcd610bfd032f28aa0f225
parentdev-python/django-otp: Bump to 1.1.2 (diff)
downloadgentoo-0b0ba372.tar.gz
gentoo-0b0ba372.tar.bz2
gentoo-0b0ba372.zip
dev-python/rich: Bump to 10.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.15.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 1cbe7c6cf932..e279380488bf 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -2,3 +2,4 @@ DIST rich-10.12.0.tar.gz 16265099 BLAKE2B c2249be5a5008e3e9fd5c301b10d7bc544e480
DIST rich-10.13.0.tar.gz 16277448 BLAKE2B e33bca376e1a5b82d0648c7bdda9ce30930b7c095cd8272b573f52dcb056a21be35fb0ef83c939e7feeb458eb4efb7767bf98706a4c58fc134627a0b0f3aa68d SHA512 23ea811fbaa8002416530975fe79c62b42d3c79806d312c172351f632864356be77063d5dc0fe0243d78479fb31a87433a432b115f5cf570f7c6e44c6f773ff0
DIST rich-10.14.0.tar.gz 16276866 BLAKE2B bc7d9a493dd4d283b0890bf385ac219c60cfb80addc226b39418ff26ca598a96c71e56ce7bea34b0508728d5535ed8ef71b21b907c13bb2ac3a1c79afefeb8f2 SHA512 be5f36ca19e4c353b94030f65abd7177f8a8194a2b6d46554c29aaa3e57fca585892634e2b096f407e6ae4ae47a7f9844fb7686c34e10d4bbccb0ea35a7d2247
DIST rich-10.15.0.tar.gz 16279650 BLAKE2B c169ca3d9144349770a0baf56d6267d5ac2e8505878838c233561961c0f1f4c5dee9585e241ee730346935134162652368f735f3f9c8cf20fa43272bc99f0e68 SHA512 8c853221761199b8d3a07c38bf4ca3c355fb5618c6c0edeccd55ad88ea68907cd8d80075824bfd83ad88c9c06a2ddf46e52d88934670040bf74262128e241e89
+DIST rich-10.15.1.tar.gz 16279572 BLAKE2B e91a9d168d88c1d8db4b0901809c4da29d32b2dd582b0a7584a2f20cc60ff4418a95e593c9085babb948c0ffb4568da3b752e60d36adfc85ee704d7dd4dfc7e7 SHA512 9544f00eaddbb69cb95a16a0cd780acff38a49cdc6e35217e88ed462333e17b295dc5fdd3bf1ae25ab5e9100804e1d055b0d81bd0bca805e7b433238313f2edd
diff --git a/dev-python/rich/rich-10.15.1.ebuild b/dev-python/rich/rich-10.15.1.ebuild
new file mode 100644
index 000000000000..05ddc3dab2e6
--- /dev/null
+++ b/dev-python/rich/rich-10.15.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}