summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-03 22:25:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-03 23:54:48 +0200
commit0b15411a568deb1de376f25ad6fc601d648b5a44 (patch)
tree41c22dccb17cc640146483bd03eda10ee6898f83
parentdev-python/jeepney: Bump to 0.8.0 (diff)
downloadgentoo-0b15411a568deb1de376f25ad6fc601d648b5a44.tar.gz
gentoo-0b15411a568deb1de376f25ad6fc601d648b5a44.tar.bz2
gentoo-0b15411a568deb1de376f25ad6fc601d648b5a44.zip
dev-python/zipp: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.8.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index da4ee7e9e7c0..2bd0dc6421ab 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.7.0.tar.gz 12989 BLAKE2B 8a315dfd28c8aa1d5a568699886ea47b34000381981d1f4e578bcc10d7c9dc772bfd99ae9d720836e300dd1aaa5e12f0667bbe40d69668306f90aed23ec0cc8f SHA512 bf0c00382273453286ce597fb5a0059b8b279edd01dc4f2d5accef41cc53d69ddda1a2b00f4c38ed4057eeac69ef225ba4bd3a70a16da025b33947cdd6a69ed8
+DIST zipp-3.8.0.tar.gz 13344 BLAKE2B 0da3ca4ff683ac840759030b6ee5125bb1a1b1b8737f0ff0499f3193d13dc3163c6c1fd29c5f1667f347728c991930e3d9e3a325ffb89b6fecb9f6590887bcaa SHA512 d677f941dc92a784b8bd197ca2e1f6f3a570dc236c9eeddcb6108d6f55ad3d35a82462abeeb4bac6ea434442737aea960d941c2a7d0bd416da9abee153c99bb8
diff --git a/dev-python/zipp/zipp-3.8.0.ebuild b/dev-python/zipp/zipp-3.8.0.ebuild
new file mode 100644
index 000000000000..e12ba8698422
--- /dev/null
+++ b/dev-python/zipp/zipp-3.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+src_prepare() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}