summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-09 15:16:41 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-09 15:16:41 +0200
commit0b17a0a097b0c5484f704d7d0b8b989183a6820e (patch)
tree6aaa2057cfcd3575f934507aa15bec7ac1a85a56
parentapp-crypt/aespipe: update EAPI 7 -> 8 (diff)
downloadgentoo-0b17a0a097b0c5484f704d7d0b8b989183a6820e.tar.gz
gentoo-0b17a0a097b0c5484f704d7d0b8b989183a6820e.tar.bz2
gentoo-0b17a0a097b0c5484f704d7d0b8b989183a6820e.zip
app-crypt/p11-kit: drop 0.23.22, 0.25.0
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-crypt/p11-kit/Manifest1
-rw-r--r--app-crypt/p11-kit/p11-kit-0.23.22.ebuild48
-rw-r--r--app-crypt/p11-kit/p11-kit-0.25.0.ebuild48
3 files changed, 0 insertions, 97 deletions
diff --git a/app-crypt/p11-kit/Manifest b/app-crypt/p11-kit/Manifest
index 043487f5f573..19269a7fd9f1 100644
--- a/app-crypt/p11-kit/Manifest
+++ b/app-crypt/p11-kit/Manifest
@@ -1,3 +1,2 @@
-DIST p11-kit-0.23.22.tar.xz 830016 BLAKE2B 4e1edfd9e2441d237c07a16c003aee5ffde38f1cf545c26e435645429f2cfa4fe7ca61cdc3c3940390aa040ba991f2ee3995b14cc31bb886d5eeffa8ed5e1721 SHA512 098819e6ca4ad9cc2a0bc2e478aea67354d051a4f03e6c7d75d13d2469b6dc7654f26b15530052f6ed51acb35531c2539e0f971b31e29e6673e857c903afb080
DIST p11-kit-0.24.1.tar.xz 838304 BLAKE2B e5cb98881279199e2674e2ff4f12d72c4d126c54429ee7ece6dd56ad1987f84abf58a67b8bf2405b19a5bca9d1106f8ec901364ac3d2488f65b3f92b51f850fe SHA512 8cf170c714bb9e0cf3df93e8ec55b8e3c55cabf2c6a27f177ac6de8b8028985df2ca0216d3215d6828dc2ae3095c4e1a4febe8cb26b88ec321defc66bb011e81
DIST p11-kit-0.25.0.tar.xz 958940 BLAKE2B 6ffce977f86c516a327afe50f4cc5a36e86ba7f43c6cb555db419d9e4ba7543a9f1847ba83da348cd6d7bbebe55dfa26cfe3a3aaa3e1d5420a4b8dc6cbbff088 SHA512 e6df3cb224f6ff5671bd3c0557503b5f20bbfded1b6ec340b1dafcbd1b1725ea2d41d0e920756716e0fe9cb28270d115fe77b23ec876a15007b22e3f30d015fe
diff --git a/app-crypt/p11-kit/p11-kit-0.23.22.ebuild b/app-crypt/p11-kit/p11-kit-0.23.22.ebuild
deleted file mode 100644
index fdc123c2b489..000000000000
--- a/app-crypt/p11-kit/p11-kit-0.23.22.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal
-
-DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
-HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
-SRC_URI="https://github.com/p11-glue/p11-kit/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+asn1 debug +libffi systemd +trust"
-REQUIRED_USE="trust? ( asn1 )"
-
-RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}] )
- libffi? ( dev-libs/libffi:=[${MULTILIB_USEDEP}] )
- systemd? ( sys-apps/systemd:= )
- trust? ( app-misc/ca-certificates )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-pkg_setup() {
- # disable unsafe tests, bug#502088
- export FAKED_MODE=1
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable trust trust-module) \
- $(use_with trust trust-paths "${EPREFIX}"/etc/ssl/certs/ca-certificates.crt) \
- $(use_enable debug) \
- $(use_with libffi) \
- $(use_with asn1 libtasn1) \
- $(multilib_native_use_with systemd)
-
- if multilib_is_native_abi; then
- # re-use provided documentation
- ln -s "${S}"/doc/manual/html doc/manual/html || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/app-crypt/p11-kit/p11-kit-0.25.0.ebuild b/app-crypt/p11-kit/p11-kit-0.25.0.ebuild
deleted file mode 100644
index 46287250efa9..000000000000
--- a/app-crypt/p11-kit/p11-kit-0.25.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 meson-multilib
-
-DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
-HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
-SRC_URI="https://github.com/p11-glue/p11-kit/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+libffi gtk-doc nls systemd test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-misc/ca-certificates
- >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}]
- libffi? ( dev-libs/libffi:=[${MULTILIB_USEDEP}] )
- systemd? ( sys-apps/systemd:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- gtk-doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
-"
-
-multilib_src_configure() {
- # Disable unsafe tests, bug#502088
- export FAKED_MODE=1
-
- local emesonargs=(
- -Dbashcompdir="$(get_bashcompdir)"
- -Dtrust_module=enabled
- -Dtrust_paths="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
- $(meson_feature libffi)
- $(meson_use nls)
- $(meson_use test)
- $(meson_native_use_bool gtk-doc gtk_doc)
- $(meson_native_true man)
- $(meson_native_use_feature systemd)
- )
-
- meson_src_configure
-}