summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-11 15:40:13 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-11 16:52:21 +0200
commit0b1d4526ca46892684722f203878ead0780d7b81 (patch)
tree34ce364dc21752e8de1d22ec6fb8f4ad178925f5
parentmedia-libs/gstreamer-editing-services: bump to 1.10.3 (diff)
downloadgentoo-0b1d4526ca46892684722f203878ead0780d7b81.tar.gz
gentoo-0b1d4526ca46892684722f203878ead0780d7b81.tar.bz2
gentoo-0b1d4526ca46892684722f203878ead0780d7b81.zip
media-libs/gst-rtsp-server: bump to 1.10.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.10.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index e292b4c36c68..b82fdfba97bb 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,2 +1,3 @@
DIST gst-rtsp-0.10.8.tar.bz2 567670 SHA256 9915887cf8515bda87462c69738646afb715b597613edc7340477ccab63a6617 SHA512 c5020cffa9334b7d9c6b9dbe6f32bd4580eeee1c67689269d232e954ef9d96d8b988e3fb19da89701eae26419df0bf6de5796f7780cfbedda4c07154b1c1ebd7 WHIRLPOOL 6bd260edaef5ab003ef7176d84c46d5a94d365af51226108af9ab845d6e5910d90c721d5fd87e7fe93b141a82e5114b4c674a1d2500ef57302bf845c87f5463c
+DIST gst-rtsp-server-1.10.3.tar.xz 628808 SHA256 baf9f7d229711cb3d823a447a930132f809b3321eab3535491bb01c8a21566fe SHA512 08bd56a04dbfda9d9509385e0ae255f596a4da36d0f998c3c7cb319f7050d3fb8718d11bb3304c667351a859e332f39b8013579cbc70cdb978cb358ae6063f7c WHIRLPOOL e323888dedb1f15360c27015d0176edfb58d70d11d859fa3768f73cefe4d1d6f694652af64268296eab5480588c7e864f8739d86d615009c38ac29bfd8c58d52
DIST gst-rtsp-server-1.8.3.tar.xz 601536 SHA256 010f06800c1c957851d1352e5ec7a8ba3ce6a857fec1b8afc7d1a9e5f53288bf SHA512 576b4d39abd5d6903da8dd1a0b1d5464e52ec050bad27cec304ad30f4e839e7ec18f07808e1d43f4b10ba469f02f32c6c494a285480347cdf9967de1723bc9fe WHIRLPOOL f7ac6f592f5341d46d19b3e3930ed362d71b44518ff5ceb1f11ad893f5976c27567f83d6836b28fc2d93152853a09c84b3b8558f2e19f047fbb8f364fad29c51
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.10.3.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.10.3.ebuild
new file mode 100644
index 000000000000..272376de26ae
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.10.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://people.freedesktop.org/~wtay/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# FIXME: check should depend on USE=test but check is losy
+# configure says good and bad are required by macros forces them to be optional
+# they are only used in unittests anyway.
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.12
+ test? (
+ >=media-libs/gst-plugins-bad-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ )
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-examples \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}