summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-14 03:44:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 04:23:35 +0100
commit0b28f6c85f1063d14efedfc8f0936a5b8cfd952a (patch)
tree9a1bb705382b6418dbed8394ad5a0189e34107d3
parentdev-python/black: Remove old (diff)
downloadgentoo-0b28f6c85f1063d14efedfc8f0936a5b8cfd952a.tar.gz
gentoo-0b28f6c85f1063d14efedfc8f0936a5b8cfd952a.tar.bz2
gentoo-0b28f6c85f1063d14efedfc8f0936a5b8cfd952a.zip
dev-python/python-mpd2: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-mpd2/Manifest1
-rw-r--r--dev-python/python-mpd2/python-mpd2-3.1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-mpd2/Manifest b/dev-python/python-mpd2/Manifest
index 9f2197ad234c..7ea9e9852029 100644
--- a/dev-python/python-mpd2/Manifest
+++ b/dev-python/python-mpd2/Manifest
@@ -1 +1,2 @@
DIST python-mpd2-3.1.0.gh.tar.gz 69162 BLAKE2B fb9b13f3e73b654d7e2a6ee84907f84ebf354d8f56ee47f58046a28aef1d43b5ddd52bf51f42a3e56dd6d8036010abc74d5537cfe8cf4f976b0a758506879dfe SHA512 9d8dd774540d9e09804fd293ce362401b2253f8021c1581c0764bac0b61d2e4b5f50bb752e5d774459194a717354f28ad5d96d48f29ef0f54011969ec91ff106
+DIST python-mpd2-3.1.1.gh.tar.gz 69613 BLAKE2B 4769799edb7a5fa8d772e95fdda362845d97ff2e17bc5eed7ec057c0e17389e8ad3b5d1ecd3b169ddea9d33fdfc52d46b86b8e1abc89489cf04f53aa803219d0 SHA512 abd882bc0652ed4a8ee2f4abf0a039e7c62e77b35d278c5fc99bb032c220caac831cc483445516044964f2ea078d2134af61c64d55cb20770b4d32a5aa1ce5e2
diff --git a/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild b/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild
new file mode 100644
index 000000000000..91c77bfc32d1
--- /dev/null
+++ b/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/
+"
+# as of 3.1.0, sdist is missing some doc files
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="
+ twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest mpd.tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}