summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-29 00:17:24 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-29 00:18:09 +0100
commit0b375a9e5564db7b2a5e3d7422fc75c638a66efb (patch)
tree6cb35bdd4c93da22f9d029ec786578d8e3f76690
parentdev-util/pycharm-professional: Version bump (diff)
downloadgentoo-0b375a9e5564db7b2a5e3d7422fc75c638a66efb.tar.gz
gentoo-0b375a9e5564db7b2a5e3d7422fc75c638a66efb.tar.bz2
gentoo-0b375a9e5564db7b2a5e3d7422fc75c638a66efb.zip
dev-util/pycharm-community: Version bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-5.0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index c89d85e2b861..bddce4641023 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -3,3 +3,4 @@ DIST pycharm-community-4.0.6.tar.gz 121278114 SHA256 7aa0ed3d743ed6886329671d2e5
DIST pycharm-community-4.5.4.tar.gz 121580731 SHA256 6bdd344eb88ee50cf29e98278c87faad0d1a23a7ec84c1794b956d2633024228 SHA512 e0c90fd84d60e1ac644c2b29aef484c1768cf8832c70cbc1a7905b64e0ef0fd7ec50665b9b15fcdaad762852e42103487b59fc4c8d1e711fd3a30123f8c959eb WHIRLPOOL d3725d9f3d983edf111f8aeb903bced2df643e9b39dcff59f21c176a16d9304dfe833ee542e204d1a4f5cdfadb33025587a669f190202bbae83cd9d102250c08
DIST pycharm-community-5.0.2.tar.gz 136420461 SHA256 eadc36ae55237b783fbc528b6007e1755606ef7a95b7cc8dec27f44a829e545b SHA512 f8eabd233a70ea27f8eeb8b2307b749673c64a3b1a897c773665959dccfbc43a1f62afab4e9be117e29cfa7d0608ec3cf1a87b4b0d2da44b9c83cf8205d1cdbb WHIRLPOOL acd6948edd78ec17beb9f264985619c662d113b7d8f6c9c549b958d780e974019466eb5e1060705be5f1e75581c106a92bf95ad958357197f4fc0bc3db79f8b9
DIST pycharm-community-5.0.3.tar.gz 136122878 SHA256 82116e6e5bf41ecd48f4fab04012e4a75eefef9f5856083642c4524461c763f5 SHA512 ee238b71f54cad9dd1e0ee700ec9cab5db5b0f8422b6cb97fa966bdb074ad6b05387a98ad208f87073adbb5fbf31d7c821222f7593791005f5cb3604b965f849 WHIRLPOOL 9bc4f9fb388b8f2b954012ae655c2dd4f3cdd8c30bee91389029aeb3568d54431906e2b5dd34db60768c2ef460cae903346e64a64f5895a6d7574ab07672a2a1
+DIST pycharm-community-5.0.4.tar.gz 135699433 SHA256 edd4bdd74a05fc4bf05c0b9cc3117a320050e1360f5d8adf8de29288d1a19972 SHA512 628ee0f057cfa06b9234d21ed887b71d41b4059e003b441dcee8662d08e71eae6bb9c6bbc587e4a4bc1eae913404c4102446e42a771e5cd63eef2a5d0110f020 WHIRLPOOL 5b9c0a3bbfb8511ddeb637e27da945fa04ba620444287050e3e3fc6606e55ad22201c4f3232b4db086bbbcc085d19ec5a38943db980d50f358a3fec6da77e6d5
diff --git a/dev-util/pycharm-community/pycharm-community-5.0.4.ebuild b/dev-util/pycharm-community/pycharm-community-5.0.4.ebuild
new file mode 100644
index 000000000000..4a5706ec3cf9
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-5.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_src_install
+}