summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 15:05:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 15:05:35 +0100
commit0b48adda7c8036b3c90154c3c176a76c2be567be (patch)
tree935d239a9807744649525e4c77fb9c8cf1453ee0
parentdev-python/humanize: Remove old (diff)
downloadgentoo-0b48adda7c8036b3c90154c3c176a76c2be567be.tar.gz
gentoo-0b48adda7c8036b3c90154c3c176a76c2be567be.tar.bz2
gentoo-0b48adda7c8036b3c90154c3c176a76c2be567be.zip
dev-python/httplib2: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.20.2.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index e00e914ecd83..f8ca93a5252a 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,2 +1 @@
-DIST httplib2-0.20.2.gh.tar.gz 407815 BLAKE2B ebb3a35b5842eff570c4d804e5dcffa5afde32841eaf1797afd47a58ff7e4d6f945b20c82ad10afe0abff1dd8c5fb405594dca0c6641f8a7a201a71258478c52 SHA512 cb1e0e365ec7872d20c1a8e3ddb150433dd01f4ec816ae2044be6aad6c21afd00ce00dfc57f1348dcc857a63e02e8ffbd39c78f35bb4bba2e283a48f07102159
DIST httplib2-0.20.4.gh.tar.gz 371778 BLAKE2B 85e2dd0b6213cc5015d4f2f7f923209a61649f948f003eaf3c95c956cb08e6f5bf9dc4e40109c0ddea6a18ab47870a21c7d367ea1eeec2644507568f4e271005 SHA512 46396a9bb439e61939e481a2502567a6dc40686471267ea4c357f141ac138193107f90ac465db683e4ab71e5d92249b810657bff0cb74af7a37a9a23c8320741
diff --git a/dev-python/httplib2/httplib2-0.20.2.ebuild b/dev-python/httplib2/httplib2-0.20.2.ebuild
deleted file mode 100644
index 4c8a2f6fd6ce..000000000000
--- a/dev-python/httplib2/httplib2-0.20.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="https://pypi.org/project/httplib2/"
-SRC_URI="
- https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- app-misc/ca-certificates
- dev-python/pyparsing[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-libs/openssl
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- # the bundled certificates use weak MDs
- pushd tests/tls >/dev/null || die
- ../../script/generate-tls || die
- popd >/dev/null || die
-
- # recerting increases serial numbers
- sed -e 's:E2AA6A96D1BF1AEC:E2AA6A96D1BF1AEF:' \
- -e 's:E2AA6A96D1BF1AED:E2AA6A96D1BF1AF0:' \
- -i tests/test_https.py || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by using system certificates
- tests/test_cacerts_from_env.py::test_certs_file_from_builtin
- tests/test_cacerts_from_env.py::test_certs_file_from_environment
- tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
-
- # broken by new PySocks, probably
- tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
- tests/test_proxy.py::test_socks5_auth
-
- # broken by recerting (TODO)
- tests/test_https.py::test_min_tls_version
- tests/test_https.py::test_max_tls_version
- )
-
- # tests in python* are replaced by tests/
- # upstream fails at cleaning up stuff
- epytest tests
-}