summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 14:25:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 15:08:33 +0100
commit0b7fdcf2a3714570eccc0d974265320194d50922 (patch)
treea98c417521af8d4b5da8afa3bd229f479a8cfc01
parentkernel-install.eclass: Refactor /usr/src/linux check to function (diff)
downloadgentoo-0b7fdcf2a3714570eccc0d974265320194d50922.tar.gz
gentoo-0b7fdcf2a3714570eccc0d974265320194d50922.tar.bz2
gentoo-0b7fdcf2a3714570eccc0d974265320194d50922.zip
kernel-install.eclass: Update symlink if target has no sources
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--eclass/kernel-install.eclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 107a526c328f..860105feb8b8 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -89,6 +89,9 @@ kernel-install_can_update_symlink() {
# if the symlink does not exist or is broken, update
[[ ! -e ${target} ]] && return 0
+ # if the target does not seem to contain kernel sources
+ # (i.e. is probably a leftover directory), update
+ [[ ! -e ${target}/Makefile ]] && return 0
local symlink_target=$(readlink "${target}")
# the symlink target should start with the same basename as target