summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:51:36 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:21 +0100
commit0b9c71656d6fe173e5d34d05bb62fb3d17043ddd (patch)
treee4d46286a7dd07f0a6e994d56623a2e341b67ff5
parentx11-wm/musca: respect PKG_CONFIG and depend on it (diff)
downloadgentoo-0b9c71656d6fe173e5d34d05bb62fb3d17043ddd.tar.gz
gentoo-0b9c71656d6fe173e5d34d05bb62fb3d17043ddd.tar.bz2
gentoo-0b9c71656d6fe173e5d34d05bb62fb3d17043ddd.zip
app-misc/gcal: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/gcal/gcal-3.6.3.ebuild10
-rw-r--r--app-misc/gcal/gcal-4.1.ebuild12
2 files changed, 12 insertions, 10 deletions
diff --git a/app-misc/gcal/gcal-3.6.3.ebuild b/app-misc/gcal/gcal-3.6.3.ebuild
index 9ff90a677275..f872ffb027c7 100644
--- a/app-misc/gcal/gcal-3.6.3.ebuild
+++ b/app-misc/gcal/gcal-3.6.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -14,10 +14,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="ncurses nls unicode"
-DEPEND="
- app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.17 )"
RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.17 )
+"
DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
diff --git a/app-misc/gcal/gcal-4.1.ebuild b/app-misc/gcal/gcal-4.1.ebuild
index 56c197b65ff0..5fda1b0ee397 100644
--- a/app-misc/gcal/gcal-4.1.ebuild
+++ b/app-misc/gcal/gcal-4.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -14,13 +14,13 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="ncurses nls unicode"
-DEPEND="
- app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.17 )
- unicode? ( dev-libs/libunistring:= )"
-
RDEPEND="nls? ( virtual/libintl )
unicode? ( dev-libs/libunistring:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.17 )
+"
DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )