summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-18 07:08:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-18 08:18:35 +0200
commit0bba225bc3b0aafb6600342ef42f5b8f32ae9bf7 (patch)
tree688476564d35b54f91f18dffc575df94c96704b3
parentdev-python/pylint: Remove old (diff)
downloadgentoo-0bba225b.tar.gz
gentoo-0bba225b.tar.bz2
gentoo-0bba225b.zip
dev-python/openstacksdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openstacksdk/Manifest1
-rw-r--r--dev-python/openstacksdk/openstacksdk-0.99.0.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/openstacksdk/Manifest b/dev-python/openstacksdk/Manifest
index b6c1a81737be..142400f3b752 100644
--- a/dev-python/openstacksdk/Manifest
+++ b/dev-python/openstacksdk/Manifest
@@ -1,2 +1 @@
DIST openstacksdk-0.100.0.tar.gz 1065692 BLAKE2B 7941cb9a14f10924953ad114f9bce4847b7e26bbea4622790503209ab70a01c254f2ec59d3f794f64d1ecc8f320a9a2be2db8015cccad8b20fe06dc1e72683d0 SHA512 c3e47510518bc4abac78aab654f6f8aa7c0deec3f4355ec7ea064ffa32c1862a9015806fd04cc1975c3d7e688e9c5ee66e3837baa21ae6c82db8f39b4b8f8330
-DIST openstacksdk-0.99.0.tar.gz 1060314 BLAKE2B 0c8f641e301ba4fb8ca83e651f85f8ba98aa73904b2e94b15b17d99354aace5b73ba243c4e624e4c53dd7fb1deb147801aee93233f1fe019a0068873530bdb37 SHA512 5e15f29002231dbad15e7a2dadaa97e64ed191389d259222880a7e40984d6fbcd9d1602a041164e4f819141417d108a179171b4c1430947dc5c5e9cdc5409aea
diff --git a/dev-python/openstacksdk/openstacksdk-0.99.0.ebuild b/dev-python/openstacksdk/openstacksdk-0.99.0.ebuild
deleted file mode 100644
index c93382d4051c..000000000000
--- a/dev-python/openstacksdk/openstacksdk-0.99.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of libraries for building applications to work with OpenStack"
-HOMEPAGE="https://github.com/openstack/openstacksdk/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-CDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/requestsexceptions-1.2.0[${PYTHON_USEDEP}]
- >dev-python/jsonpatch-1.20[${PYTHON_USEDEP}]
- >=dev-python/os-service-types-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/munch-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-4.4.1[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.6.5[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.7.0[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/prometheus_client-0.4.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-6.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/statsd-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # Internet?
- sed -e 's:test_create_dynamic_large_object:_&:' \
- -i openstack/tests/unit/cloud/test_object.py || die
-
- # TODO
- sed -e 's:test_generate_form:_&:' \
- -e 's:test_create_static_large_object:_&:' \
- -e 's:test_object_segment_retries:_&:' \
- -e 's:test_object_segment_retry_failure:_&:' \
- -e 's:test_slo_manifest_retry:_&:' \
- -i openstack/tests/unit/cloud/test_object.py || die
-
- # unhappy about paths due to test runner
- sed -e 's:test_method_not_supported:_&:' \
- -i openstack/tests/unit/test_exceptions.py || die
- sed -e 's:test_repr:_&:' \
- -i openstack/tests/unit/test_resource.py || die
-
- # requires hacking
- rm openstack/tests/unit/test_hacking.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # functional tests require cloud instance access
- eunittest -b openstack/tests/unit
-}