summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-12-25 12:18:52 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-12-25 12:18:52 +0700
commit0bd453e6eb1e077f7ab19dec51f244b29cd420e9 (patch)
tree5d2360ea83e038d31a974c23b287f9298da5f7cb
parentapp-text/crengine-ng: bump to 0.9.3 (diff)
downloadgentoo-0bd453e6eb1e077f7ab19dec51f244b29cd420e9.tar.gz
gentoo-0bd453e6eb1e077f7ab19dec51f244b29cd420e9.tar.bz2
gentoo-0bd453e6eb1e077f7ab19dec51f244b29cd420e9.zip
app-text/crqt-ng: bump to 1.0.3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--app-text/crqt-ng/Manifest1
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.3.ebuild41
-rw-r--r--app-text/crqt-ng/metadata.xml4
3 files changed, 44 insertions, 2 deletions
diff --git a/app-text/crqt-ng/Manifest b/app-text/crqt-ng/Manifest
index 8684a4a14325..e674156c8415 100644
--- a/app-text/crqt-ng/Manifest
+++ b/app-text/crqt-ng/Manifest
@@ -1 +1,2 @@
DIST crqt-ng-1.0.2.tar.bz2 419058 BLAKE2B 5d8b6704e6ec226852a0c82cc6c00b386c5b348675f00c4acc9dddbee999f381616083101f183523671ef81bb5036eddb7643b3f31857535d6773a549405ab1c SHA512 f8ebf9d5dec13b69fe7440209cd4da807d25413075b4ad2de885fa73134729be5c23df7d0a73bff061171449e394474ac3779b940120f144d93a7a98eca6cf55
+DIST crqt-ng-1.0.3.tar.bz2 423741 BLAKE2B 70b43b601b9b51673b12467a108683d83d087b20867bd21f919913f98d67f367c5dc40d4bd514e4fa5534a5c0766b486e41566c44d50ab8dd85c1717a4b20742 SHA512 aab30e3f42ffcc6a1d54e777d4968df8ae864e5d25df045634fc8041b8418d1440250fe7edc865648b3031bcd39f051295e1518b9e2078ee6046aa66add42dd2
diff --git a/app-text/crqt-ng/crqt-ng-1.0.3.ebuild b/app-text/crqt-ng/crqt-ng-1.0.3.ebuild
new file mode 100644
index 000000000000..8ab0c97e1f85
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.3[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(-DUSE_QT=QT5)
+ cmake_src_configure
+}
diff --git a/app-text/crqt-ng/metadata.xml b/app-text/crqt-ng/metadata.xml
index 6aee26085f6e..78b99b69d30d 100644
--- a/app-text/crqt-ng/metadata.xml
+++ b/app-text/crqt-ng/metadata.xml
@@ -11,8 +11,8 @@
<description>upstream</description>
</maintainer>
<longdescription lang="en">
- A fork of coolreader. Supported formats are: fb2 (including fb2.zip), fb3, epub (without DRM),
- rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
+ A fork of coolreader Qt program. Supported formats are: fb2 (including fb2.zip), fb3,
+ epub (without DRM), rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
</longdescription>
<use>
<flag name="chm">Support chm format</flag>