summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 22:03:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 22:09:39 +0100
commit0c0ae73197b88f7028ca8171e741e8e4e29dfb3c (patch)
tree14a6e8dae4dbdc1f61d0fca55ca431af6752e88e
parentdev-python/setuptools: Replace virts with cond deps (diff)
downloadgentoo-0c0ae73197b88f7028ca8171e741e8e4e29dfb3c.tar.gz
gentoo-0c0ae73197b88f7028ca8171e741e8e4e29dfb3c.tar.bz2
gentoo-0c0ae73197b88f7028ca8171e741e8e4e29dfb3c.zip
dev-python/trollius: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trollius/trollius-2.1.ebuild5
-rw-r--r--dev-python/trollius/trollius-2.2.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/trollius/trollius-2.1.ebuild b/dev-python/trollius/trollius-2.1.ebuild
index 2cc2af11d175..2f3cc0f4eab5 100644
--- a/dev-python/trollius/trollius-2.1.ebuild
+++ b/dev-python/trollius/trollius-2.1.ebuild
@@ -15,7 +15,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
-RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/futures[${PYTHON_USEDEP}]
+ ' -2)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/trollius/trollius-2.2.ebuild b/dev-python/trollius/trollius-2.2.ebuild
index b0922242a535..d0780fc89424 100644
--- a/dev-python/trollius/trollius-2.2.ebuild
+++ b/dev-python/trollius/trollius-2.2.ebuild
@@ -15,7 +15,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/futures[${PYTHON_USEDEP}]
+ ' -2)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"