summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-07 20:35:46 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-07 20:37:22 +0200
commit0c0d012d0bf2f9fb660edda3f9bc6d1c20b693db (patch)
treecfc8938553bcbea3a0e592387e630c1a60f8a378
parentnet-misc/openconnect: Cleanup stoken change (diff)
downloadgentoo-0c0d012d0bf2f9fb660edda3f9bc6d1c20b693db.tar.gz
gentoo-0c0d012d0bf2f9fb660edda3f9bc6d1c20b693db.tar.bz2
gentoo-0c0d012d0bf2f9fb660edda3f9bc6d1c20b693db.zip
app-admin/calamares: Version bump 2.2
Package-Manager: portage-2.2.28
-rw-r--r--app-admin/calamares/Manifest1
-rw-r--r--app-admin/calamares/calamares-2.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
index 7ae91e51ffef..e3400e6152e3 100644
--- a/app-admin/calamares/Manifest
+++ b/app-admin/calamares/Manifest
@@ -1 +1,2 @@
DIST calamares-2.1.tar.gz 2000234 SHA256 77bfdc8fe202cd1c068680d41d3df113bd9ee28362aeded63a113bdbaa76d362 SHA512 3e90376ea7d7cc2d2bf6d7b5efffcd74c486c366964bb25e9d7243a2139f5b04007de28a1c5d60463342ed4ad2beda60360a9f117ab94aee20cb49e3d2202bb6 WHIRLPOOL d8934c6043278f292f1b4dbad14038f9afc66d77bd089fb9258dbb080d2a4a5dddea03a3527a056856413ce8f18d0af8c77287147ffd5e38231a290249d43b22
+DIST calamares-2.2.tar.gz 4728472 SHA256 b75d1462a8a7bd2bdc57ec38bd3b2e0485be573d8af13d05f44df2fc7a7dcaa4 SHA512 1b612f10cba059f8991d4e0afc06a742495929ae20daf8e57d4bca94b5836cd7cd3f3db1cbf08850c8ed55a7dd5f28f42198b6e40392b3f8cc36e8da55b95ffc WHIRLPOOL b1aeb6ff5df865c679d080f6482c50c85a6aa75768729c2194a775182f98d8b78627c66e8b49063c8f60bdec1c2f56a1fd627528fbc2a13fe8117d6c933bb212
diff --git a/app-admin/calamares/calamares-2.2.ebuild b/app-admin/calamares/calamares-2.2.ebuild
new file mode 100644
index 000000000000..9a0efdd7fba1
--- /dev/null
+++ b/app-admin/calamares/calamares-2.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="http://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="git://github.com/${PN}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtquick1)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ >=dev-cpp/yaml-cpp-0.5.1
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5]
+ >=sys-libs/kpmcore-2.1.0
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ sys-apps/gptfdisk
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/gummiboot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ sys-fs/udisks:2[systemd]
+ virtual/udev[systemd]
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=( "-DWITH_PARTITIONMANAGER=1" )
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}