summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-01 13:26:06 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-01 13:26:06 -0500
commit0c1858a2fd801a0a84f7ab04bf6d2ff52acbf1c1 (patch)
treefb989368e4398024e6c5ff9e2f3a7e19187a46b5
parentdev-python/pytest-qt: tests are broken (diff)
downloadgentoo-0c1858a2.tar.gz
gentoo-0c1858a2.tar.bz2
gentoo-0c1858a2.zip
dev-python/pytest-qt: add RESTRICT=test and fix minor white space
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
index 631c78f70aef..f99801f96289 100644
--- a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE=" MIT"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
@@ -31,6 +31,9 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
python_compile_all() {
use doc && sphinx-build -b html docs _build/html
}