summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-10-11 10:59:55 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-11 11:03:00 +0200
commit0c1903c21cb57eabf0afeec56c3c231e1f9a8e7d (patch)
treee33c384ee4df45a5c9b96e4ea41c5b3c0bf17bf1
parentsys-cluster/rdma-core: sync live (diff)
downloadgentoo-0c1903c21cb57eabf0afeec56c3c231e1f9a8e7d.tar.gz
gentoo-0c1903c21cb57eabf0afeec56c3c231e1f9a8e7d.tar.bz2
gentoo-0c1903c21cb57eabf0afeec56c3c231e1f9a8e7d.zip
sys-cluster/rdma-core: drop 43.0, 45.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/Manifest2
-rw-r--r--sys-cluster/rdma-core/rdma-core-43.0.ebuild103
-rw-r--r--sys-cluster/rdma-core/rdma-core-45.0.ebuild103
3 files changed, 0 insertions, 208 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
index c6136b48fd47..b992aacb483c 100644
--- a/sys-cluster/rdma-core/Manifest
+++ b/sys-cluster/rdma-core/Manifest
@@ -1,4 +1,2 @@
-DIST rdma-core-43.0.tar.gz 1905196 BLAKE2B 96003e32de43e3f72a28c5d2d9bc670a709b25caba6ff25a36dedc003daa315b0fbfba1a25084160e659a1f0f7aa8fe32b63b0eb29103624a9499c05ebba0a87 SHA512 d5c48cfe10af40bc1caaed48fd6f82acfee5a22e1bfcc6955098ff328c1833e5455140e8f39cd5ceaa03f0aaa2bc627d56b2c1d3af8f2f505dda8a58ea70b597
-DIST rdma-core-45.0.tar.gz 1939646 BLAKE2B e2bcc7c993e220326884df1964c73156b123b10c16bd159798fc0440cc58cd1fd32348da667778bec9627c3f3f742061917bbebb37c33a784d946c5c59f394d4 SHA512 3a6728990065867d6fd2abe2a13e3275df513a491da6e3c07a75ec79e8f9ad7fe30f6cbbf04951d0976f1318bf45e0d562c260e9d633c96e4c167d0f9fa71d1b
DIST rdma-core-47.0.tar.gz 1945228 BLAKE2B 1a1342b7166816e220849d854f551097d364173f3db95f300eed4ff416a82cfaf335ac1cbe1da6b8c1b2213b9a6cd3a476fa7ff9a266248ab40d17b21b04417e SHA512 6de17576f27204ed3e3a4a386ecd5ca20bbef4f23b16cdeacb362457db652ee790e1b1aab46499393908994f40c79e8d184ceb9995b29bc5c9ad22170d599f2e
DIST rdma-core-48.0.tar.gz 1955938 BLAKE2B 18e32486af2a88c3d3fdd3c0bb90b7f1d713a83c6027c330f71aed47ada4dec30b4840d1a35eee5d1d8745ca0d63ee1612b21454ed61265e0076485868b100f7 SHA512 48303d830e83d4fb6a88e23764380872dadc4579e8a1a62275447fe4a6613aea9ac08876e4a58f5799af9455e6dabbced8bc8e1663812fe68a2d642a1152b195
diff --git a/sys-cluster/rdma-core/rdma-core-43.0.ebuild b/sys-cluster/rdma-core/rdma-core-43.0.ebuild
deleted file mode 100644
index 8ed9652f3ab6..000000000000
--- a/sys-cluster/rdma-core/rdma-core-43.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake perl-functions python-single-r1 udev systemd
-
-DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
-HOMEPAGE="https://github.com/linux-rdma/rdma-core"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
-else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
-SLOT="0"
-IUSE="neigh python static-libs systemd valgrind"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- dev-lang/perl
- virtual/libudev:=
- neigh? ( dev-libs/libnl:3 )
- systemd? ( sys-apps/systemd:= )
- valgrind? ( dev-util/valgrind )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${COMMON_DEPEND}
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )"
-RDEPEND="${COMMON_DEPEND}
- !sys-fabric/infiniband-diags
- !sys-fabric/libibverbs
- !sys-fabric/librdmacm
- !sys-fabric/libibumad
- !sys-fabric/ibacm
- !sys-fabric/libibmad
- !sys-fabric/srptools
- !sys-fabric/infinipath-psm
- !sys-fabric/libcxgb3
- !sys-fabric/libcxgb4
- !sys-fabric/libmthca
- !sys-fabric/libmlx4
- !sys-fabric/libmlx5
- !sys-fabric/libocrdma
- !sys-fabric/libnes"
-# python is required unconditionally at build-time
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
-
-src_configure() {
- perl_set_version
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_RUNDIR=/run
- -DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
- -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
- -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
- -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
- -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
- -DENABLE_VALGRIND="$(usex valgrind)"
- -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
- -DENABLE_STATIC="$(usex static-libs)"
- -DNO_PYVERBS="$(usex !python)"
- -DNO_MAN_PAGES=1
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- udev_dorules "${ED}"/usr/share/doc/${PF}/70-persistent-ipoib.rules
-
- if use neigh; then
- newinitd "${FILESDIR}"/ibacm.init ibacm
- newinitd "${FILESDIR}"/iwpmd.init iwpmd
- fi
-
- newinitd "${FILESDIR}"/srpd.init srpd
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/sys-cluster/rdma-core/rdma-core-45.0.ebuild b/sys-cluster/rdma-core/rdma-core-45.0.ebuild
deleted file mode 100644
index 8ed9652f3ab6..000000000000
--- a/sys-cluster/rdma-core/rdma-core-45.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake perl-functions python-single-r1 udev systemd
-
-DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
-HOMEPAGE="https://github.com/linux-rdma/rdma-core"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
-else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
-SLOT="0"
-IUSE="neigh python static-libs systemd valgrind"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- dev-lang/perl
- virtual/libudev:=
- neigh? ( dev-libs/libnl:3 )
- systemd? ( sys-apps/systemd:= )
- valgrind? ( dev-util/valgrind )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${COMMON_DEPEND}
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )"
-RDEPEND="${COMMON_DEPEND}
- !sys-fabric/infiniband-diags
- !sys-fabric/libibverbs
- !sys-fabric/librdmacm
- !sys-fabric/libibumad
- !sys-fabric/ibacm
- !sys-fabric/libibmad
- !sys-fabric/srptools
- !sys-fabric/infinipath-psm
- !sys-fabric/libcxgb3
- !sys-fabric/libcxgb4
- !sys-fabric/libmthca
- !sys-fabric/libmlx4
- !sys-fabric/libmlx5
- !sys-fabric/libocrdma
- !sys-fabric/libnes"
-# python is required unconditionally at build-time
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
-
-src_configure() {
- perl_set_version
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_RUNDIR=/run
- -DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
- -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
- -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
- -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
- -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
- -DENABLE_VALGRIND="$(usex valgrind)"
- -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
- -DENABLE_STATIC="$(usex static-libs)"
- -DNO_PYVERBS="$(usex !python)"
- -DNO_MAN_PAGES=1
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- udev_dorules "${ED}"/usr/share/doc/${PF}/70-persistent-ipoib.rules
-
- if use neigh; then
- newinitd "${FILESDIR}"/ibacm.init ibacm
- newinitd "${FILESDIR}"/iwpmd.init iwpmd
- fi
-
- newinitd "${FILESDIR}"/srpd.init srpd
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}