summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-03 19:09:58 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-03 19:09:58 -0600
commit0c24cee69727d658d28e966029183a59efc4f94b (patch)
treee4ff8544f68df6f86333bf047ff3a9d81a3c3735
parentapp-arch/dpkg: replace buf patch with upstream fix in 1.21.15 (diff)
downloadgentoo-0c24cee69727d658d28e966029183a59efc4f94b.tar.gz
gentoo-0c24cee69727d658d28e966029183a59efc4f94b.tar.bz2
gentoo-0c24cee69727d658d28e966029183a59efc4f94b.zip
app-containers/skopeo: drop 1.7.0, 1.8.0, 1.10.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/skopeo/Manifest2
-rw-r--r--app-containers/skopeo/skopeo-1.10.0.ebuild49
-rw-r--r--app-containers/skopeo/skopeo-1.7.0.ebuild52
-rw-r--r--app-containers/skopeo/skopeo-1.8.0.ebuild52
4 files changed, 0 insertions, 155 deletions
diff --git a/app-containers/skopeo/Manifest b/app-containers/skopeo/Manifest
index eda2bb16745d..2b3b7c79c482 100644
--- a/app-containers/skopeo/Manifest
+++ b/app-containers/skopeo/Manifest
@@ -1,4 +1,2 @@
DIST skopeo-1.10.0.tar.gz 6460856 BLAKE2B b904a161334ef0a3eaaab8c58f0c7e4c507fa68a09f8fa8235e8a9222d48c98874c9ce878a509e2816f210ffb37dbf707ff2653212e1efbd9ad6686efb97e147 SHA512 0d64e7f12a0d10c81074a04b6c74ed6e7213f598013f1ba672c4c696e9dad5827f41f41bb817263bf8606cd051b8e24e7eab65b95d73d8a1c8bbb3eaeb9defdb
DIST skopeo-1.5.1.tar.gz 5636533 BLAKE2B 7f0e86cdee5c3250ec1280d7e71554ac2f8ad96ababe0e81dfabc00e8c128a13fc0c9c561b7a9be389d7386e9f664b95118bd2122612b9c2e8844db49769c03c SHA512 3f8c730eaa739bf2a29b82d3b04aa4eee1c09f957b61964fc8c48e59d1537bcb87b5bdf9c18fa48f9d36cf2b7ede3a1448918a20b5a3167f6ce09881a6cd3dde
-DIST skopeo-1.7.0.tar.gz 6542347 BLAKE2B 990ad594df9483ad114debeb2882ed3976306d69983ae3d91d807e2654583e7a6599ddf50152df9a937c1c64c1e5a8abb6ed83433036e7efd4ef7e911f99c191 SHA512 7d17f98e86677150fb2ddba9edae18d8b1ac8f06fba575268e6ba54c60f7b371b5e5a9eab1a4fe19da6c7e85eb79c1eef169ad2a39eff979130ee8d141bd8d6b
-DIST skopeo-1.8.0.tar.gz 6577667 BLAKE2B 21565736a13d2fcce2576fcc1ff522e81b74aff6c18058f4c994e4f0fc12efa38706ba4c07bbe35abd7e339d9080783f766b68325b01cba90c3cd82f19470aec SHA512 697242244e533b597f481005754301efed8581018cdc297e071fa24347301ddf6111d1f1d3ccc6e87e3e5a9ea606e9c6b40c47bf69d2df6b44336fb260f546de
diff --git a/app-containers/skopeo/skopeo-1.10.0.ebuild b/app-containers/skopeo/skopeo-1.10.0.ebuild
deleted file mode 100644
index eb546e4d631d..000000000000
--- a/app-containers/skopeo/skopeo-1.10.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-COMMIT=ee60474d5a4d99745aac9855797ad4b26510d786
-inherit go-module
-
-DESCRIPTION="Command line utility foroperations on container images and image repositories"
-HOMEPAGE="https://github.com/containers/skopeo"
-SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs"
-
-COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
- >=dev-libs/libassuan-2.4.3:=
- dev-libs/libgpg-error:=
- btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
- >=sys-fs/lvm2-2.02.145:="
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
- BDEPEND="dev-go/go-md2man"
-
-RESTRICT+=" test"
-
-src_compile() {
- local BUILDTAGS
- BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
- ego build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
- -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
- -o skopeo ./cmd/skopeo
- cd docs || die
- for f in *.1.md; do
- go-md2man -in ${f} -out ${f%%.md} || die
- done
-}
-
-src_install() {
- dobin skopeo
- doman docs/*.1
- insinto /etc/containers
- newins default-policy.json policy.json
- insinto /etc/containers/registries.d
- doins default.yaml
- keepdir /var/lib/atomic/sigstore
- einstalldocs
-}
diff --git a/app-containers/skopeo/skopeo-1.7.0.ebuild b/app-containers/skopeo/skopeo-1.7.0.ebuild
deleted file mode 100644
index d228fd00e921..000000000000
--- a/app-containers/skopeo/skopeo-1.7.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-COMMIT=f45ae950aacb7b61ec13223fc22269f2fe270eab
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Command line utility foroperations on container images and image repositories"
-HOMEPAGE="https://github.com/containers/skopeo"
-SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs"
-
-COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
- >=dev-libs/libassuan-2.4.3:=
- dev-libs/libgpg-error:=
- btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
- >=sys-fs/lvm2-2.02.145:="
-DEPEND="${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-
-RESTRICT+=" test"
-
-src_compile() {
- local BUILDTAGS
- BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
- set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
- -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
- -o skopeo ./cmd/skopeo
- echo "$@"
- "$@" || die
- cd docs || die
- for f in *.1.md; do
- go-md2man -in ${f} -out ${f%%.md} || die
- done
-}
-
-src_install() {
- dobin skopeo
- doman docs/*.1
- dobashcomp completions/bash/skopeo
- insinto /etc/containers
- newins default-policy.json policy.json
- insinto /etc/containers/registries.d
- doins default.yaml
- keepdir /var/lib/atomic/sigstore
- einstalldocs
-}
diff --git a/app-containers/skopeo/skopeo-1.8.0.ebuild b/app-containers/skopeo/skopeo-1.8.0.ebuild
deleted file mode 100644
index c3dcc4973b2a..000000000000
--- a/app-containers/skopeo/skopeo-1.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-COMMIT=37727a45f96ac208785b606f7772d609bf50dbc4
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Command line utility foroperations on container images and image repositories"
-HOMEPAGE="https://github.com/containers/skopeo"
-SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs"
-
-COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
- >=dev-libs/libassuan-2.4.3:=
- dev-libs/libgpg-error:=
- btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
- >=sys-fs/lvm2-2.02.145:="
-DEPEND="${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-
-RESTRICT+=" test"
-
-src_compile() {
- local BUILDTAGS
- BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
- set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
- -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
- -o skopeo ./cmd/skopeo
- echo "$@"
- "$@" || die
- cd docs || die
- for f in *.1.md; do
- go-md2man -in ${f} -out ${f%%.md} || die
- done
-}
-
-src_install() {
- dobin skopeo
- doman docs/*.1
- dobashcomp completions/bash/skopeo
- insinto /etc/containers
- newins default-policy.json policy.json
- insinto /etc/containers/registries.d
- doins default.yaml
- keepdir /var/lib/atomic/sigstore
- einstalldocs
-}