summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-10 05:50:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-10 05:50:14 +0100
commit0c280480ba2ebeaa56b0c5c00302e64d8e4e73dc (patch)
tree871cbeab1467a9c8cba9c406684c39f2e05aa62b
parentdev-python/mkdocs-material: Bump to 9.1.2 (diff)
downloadgentoo-0c280480.tar.gz
gentoo-0c280480.tar.bz2
gentoo-0c280480.zip
dev-python/sphinx-gallery: Bump to 0.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.12.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index e9e238c7dd19..bb3182d3e3b9 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-gallery-0.11.1.tar.gz 393927 BLAKE2B c4c56e7bc7bfc519cd172cd104cfee902524c70de7fe76cc816d8f4612cbdf1a0786e3d5f83ea74ce7c1726eeaea5db45682efa3d873efeac49d94ab1393b9ac SHA512 514139213516851fe09aac4168d8fff72e5ce62eecdb0864f58e45d5fe6eab58b8fda749b72ae98f94b2bf8ac1a917396195d8a4d1750ec1563b30b879b12b8d
DIST sphinx-gallery-0.12.0.tar.gz 402165 BLAKE2B 679b51041df7593a693116a558a0b297367b230f447f53821408631ef92f301e003d1c8446b4b3666b8836149f806b92a5f101993c4f0b395df983a49ef77101 SHA512 e086c9f4ca3c8f2018c88cf6d32e644735ddec0cf85a12757a36da93c6eda43bb77d64573b963fdcf7a2e24a8123ec675af48d2500eaed040ed91bde5f776b59
+DIST sphinx-gallery-0.12.1.tar.gz 402470 BLAKE2B e198679edca69be0a3ad01a3ddc45f909dbfa5771aa5f1dc3cb3bc4fc51d0b4565f28e2462c466386cd5982720b62ea28e3f4df7befbfd747042092fbf5387d8 SHA512 030423e4ff259d5e373c85bc04460598714ce8895a63537bcd96b9a903ddf44d05bfa4ecf15853f98391a9f35dc689406abb2d6fb1eaab0e40981806cd045241
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.12.1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.12.1.ebuild
new file mode 100644
index 000000000000..fb10706de391
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.12.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+)