summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-11 02:33:31 +0100
committerSam James <sam@gentoo.org>2024-05-11 02:33:31 +0100
commit0c3d907220cac2892ac156a9257866f36a944e1d (patch)
tree8fab7c4fe8de3a5f38c57f6c3f016dc062a4bbe2
parentdev-perl/Perl-Tidy: add 20240511.0.0 (diff)
downloadgentoo-0c3d907220cac2892ac156a9257866f36a944e1d.tar.gz
gentoo-0c3d907220cac2892ac156a9257866f36a944e1d.tar.bz2
gentoo-0c3d907220cac2892ac156a9257866f36a944e1d.zip
dev-lang/perl: fix -Wimplicit-int in prefix check
-Wimplicit-int becomes an error by default in newer compilers. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/perl/perl-5.38.2-r2.ebuild2
-rw-r--r--dev-lang/perl/perl-5.38.2-r3.ebuild2
-rw-r--r--dev-lang/perl/perl-5.38.2-r4.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/perl/perl-5.38.2-r2.ebuild b/dev-lang/perl/perl-5.38.2-r2.ebuild
index a6120f17e34e..3f586f1612f2 100644
--- a/dev-lang/perl/perl-5.38.2-r2.ebuild
+++ b/dev-lang/perl/perl-5.38.2-r2.ebuild
@@ -650,7 +650,7 @@ src_configure() {
if use prefix ; then
# Set a hook to check for each detected library whether it actually works.
export libscheck="
- ( echo 'main(){}' > '${T}'/conftest.c &&
+ ( echo 'int main(){}' > '${T}'/conftest.c &&
$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"
diff --git a/dev-lang/perl/perl-5.38.2-r3.ebuild b/dev-lang/perl/perl-5.38.2-r3.ebuild
index 025d3b8ae213..56925312ea9f 100644
--- a/dev-lang/perl/perl-5.38.2-r3.ebuild
+++ b/dev-lang/perl/perl-5.38.2-r3.ebuild
@@ -680,7 +680,7 @@ src_configure() {
if use prefix ; then
# Set a hook to check for each detected library whether it actually works.
export libscheck="
- ( echo 'main(){}' > '${T}'/conftest.c &&
+ ( echo 'int main(){}' > '${T}'/conftest.c &&
$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"
diff --git a/dev-lang/perl/perl-5.38.2-r4.ebuild b/dev-lang/perl/perl-5.38.2-r4.ebuild
index 64babaaa08fb..736657d7a501 100644
--- a/dev-lang/perl/perl-5.38.2-r4.ebuild
+++ b/dev-lang/perl/perl-5.38.2-r4.ebuild
@@ -680,7 +680,7 @@ src_configure() {
if use prefix ; then
# Set a hook to check for each detected library whether it actually works.
export libscheck="
- ( echo 'main(){}' > '${T}'/conftest.c &&
+ ( echo 'int main(){}' > '${T}'/conftest.c &&
$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"