summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-02-23 01:55:09 +0300
committerMichał Górny <mgorny@gentoo.org>2018-02-23 21:38:52 +0100
commit0c5415f0cd1908fef0a9c68708fa8c37e0d07e0a (patch)
tree991894a2a655ec09f1213bf30c715cd0f6b252ed
parentmedia-video/mpv: cleanup mpv-bash-completion postinst check (diff)
downloadgentoo-0c5415f0cd1908fef0a9c68708fa8c37e0d07e0a.tar.gz
gentoo-0c5415f0cd1908fef0a9c68708fa8c37e0d07e0a.tar.bz2
gentoo-0c5415f0cd1908fef0a9c68708fa8c37e0d07e0a.zip
media-video/mpv: migrate to eapi7-ver from versionator
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--media-video/mpv/mpv-9999.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 581119576d34..1819d5337baa 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -8,7 +8,7 @@ PYTHON_REQ_USE='threads(+)'
WAF_PV=1.9.8
-inherit flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs versionator waf-utils xdg-utils
+inherit eapi7-ver flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="https://mpv.io/"
@@ -284,14 +284,10 @@ pkg_postinst() {
local rv softvol_0_18_1=0 osc_0_21_0=0 txtsubs_0_24_0=0 opengl_0_25_0=0
for rv in ${REPLACING_VERSIONS}; do
- version_compare ${rv} 0.18.1
- [[ $? -eq 1 ]] && softvol_0_18_1=1
- version_compare ${rv} 0.21.0
- [[ $? -eq 1 ]] && osc_0_21_0=1
- version_compare ${rv} 0.24.0
- [[ $? -eq 1 ]] && txtsubs_0_24_0=1
- version_compare ${rv} 0.25.0
- [[ $? -eq 1 ]] && ! use opengl && opengl_0_25_0=1
+ ver_test ${rv} -lt 0.18.1 && softvol_0_18_1=1
+ ver_test ${rv} -lt 0.21.0 && osc_0_21_0=1
+ ver_test ${rv} -lt 0.24.0 && txtsubs_0_24_0=1
+ ver_test ${rv} -lt 0.25.0 && ! use opengl && opengl_0_25_0=1
done
if [[ ${softvol_0_18_1} -eq 1 ]]; then