summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-14 06:48:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-14 07:33:44 +0200
commit0c613ab099ce9ae96e87785fe5797487a5d8ffa4 (patch)
tree639d7f5fa539c2f9012942840bf751e42ab978fe
parentdev-python/jsonschema: Bump to 4.18.3 (diff)
downloadgentoo-0c613ab099ce9ae96e87785fe5797487a5d8ffa4.tar.gz
gentoo-0c613ab099ce9ae96e87785fe5797487a5d8ffa4.tar.bz2
gentoo-0c613ab099ce9ae96e87785fe5797487a5d8ffa4.zip
dev-python/vdirsyncer: Bump to 0.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.19.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index 949426fd2e96..d5e99acd48c1 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1,2 +1,3 @@
DIST vdirsyncer-0.18.0.tar.gz 115125 BLAKE2B d81bb9b51658d16a3b9ea044846561a1ce2dac3a839d7e0a165f0136069fcd0716525ab2b908be7cafed60846a1aed6fd72aa1d31fc2a38dbe6de8d0e6585226 SHA512 7fb3d0f7d982d8390d278de1a620231e6ead1ec64057c5dbac98dcff491fa3e6b9ed8ba953995458e393aab73b0b9ab8ba14010e06f90a04d8ee2c28c7c7fbfd
DIST vdirsyncer-0.19.1.tar.gz 122699 BLAKE2B 31fd6351046f5e668312594fa698a647e67f4b66e989a60c2bc6312748f09ea7971d3b5c04ceacbedbb7618e75febfdf175a82f286ca9425f14828ff044997d5 SHA512 2b0917bf69cfa298600b6b35b50db12ca57e1a963baf2ea9839a3c2f9f686f2f83f47c01e44ad2e12287ecfd470fe1a9ee4a756c0f8985236c2fe8d0454b6a15
+DIST vdirsyncer-0.19.2.tar.gz 123389 BLAKE2B 35cf5e52f669307c7bc545404135bfb5ded3ca6a1b151735ddacd73835054a2e0ab518201ad206929ca845c2a2828c025a918bba54b739db3fa0a8e4e9f5de33 SHA512 056c58011d0a054a8cc215e9eabc706dfffb7d38deab5ae47311565b3bdb6de7a4772e97a0a50cdce33c82b09d559f1ec9cf9c84746553badf1d25791c7e08ce
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.19.2.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.19.2.ebuild
new file mode 100644
index 000000000000..dcbb0c4450f7
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.19.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi systemd
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="
+ https://github.com/pimutils/vdirsyncer/
+ https://pypi.org/project/vdirsyncer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.8.0[${PYTHON_USEDEP}]
+ <dev-python/aiostream-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/aiostream-0.4.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/system/utils/test_main.py::test_request_ssl
+ )
+
+ epytest -o addopts=
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ systemd_douserunit contrib/vdirsyncer.{service,timer}
+}