summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-06-30 22:41:10 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-06-30 22:41:10 +0900
commit0c680f35ae867aa60cf79aa028d3dfa465ead7dd (patch)
treeb439cc24ab454b00d65faa06fdee7c58b8d9f62b
parentapp-i18n/ibus-table: drop old (diff)
downloadgentoo-0c680f35.tar.gz
gentoo-0c680f35.tar.bz2
gentoo-0c680f35.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.13.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 41fc0ab15eb4..280272929e62 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.12.4.tar.gz 1371890 BLAKE2B e0d531bdd38e536ac9fc92465a651e971969278ab4826198d12399ebb1cd747d1f5d21713ecc86311ab3995b04a2842d230da8caed962045a959ba136f197cb1 SHA512 3e175dad8d9e12be91f6b6878b67301bbbf04c55e43d483162d3b10d2edbdcf1077d1f37beea2ef36323eb7de289a0c60cd3d055357a580e5d18bcc642bb907c
+DIST ibus-table-1.13.3.tar.gz 1408143 BLAKE2B fda380e284a996d34053f6bae543ebc2c072ffbd870a9421b76f18a3fa5e45ca6e687818f40bd1335791f1b92dc7ffa1ccc35c7cb55d1a6ade26bc958a2bf8d4 SHA512 2959b2f96c9a490032dafbce2b4164fcc07797ab73e735f26003156a891e1e3760e6a4f42713084b5ce1e408cbe21c3060d99615d898fe50b8d51405dcd42a3b
diff --git a/app-i18n/ibus-table/ibus-table-1.13.3.ebuild b/app-i18n/ibus-table/ibus-table-1.13.3.ebuild
new file mode 100644
index 000000000000..2a67dd2b2766
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.13.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}