summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-08 22:34:51 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-09 18:10:21 +0200
commit0c6e5e37850a20a87c3c3e2d58aa61e75c658a08 (patch)
treea30052b9a90050042e5dd8f15b206f60e11504b7
parentdev-python/pypy-bin: Fix accidental unconditional gdbm CFFI build (diff)
downloadgentoo-0c6e5e37850a20a87c3c3e2d58aa61e75c658a08.tar.gz
gentoo-0c6e5e37850a20a87c3c3e2d58aa61e75c658a08.tar.bz2
gentoo-0c6e5e37850a20a87c3c3e2d58aa61e75c658a08.zip
dev-python/pypy: Add missing resource CFFI build
-rw-r--r--dev-python/pypy/pypy-5.1.1.ebuild3
-rw-r--r--dev-python/pypy/pypy-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pypy/pypy-5.1.1.ebuild b/dev-python/pypy/pypy-5.1.1.ebuild
index 07c8352a9f85..36697f536c28 100644
--- a/dev-python/pypy/pypy-5.1.1.ebuild
+++ b/dev-python/pypy/pypy-5.1.1.ebuild
@@ -230,7 +230,8 @@ src_install() {
# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
- cffi_targets=( audioop syslog pwdgrp )
+# "resource": "_resource_build.py" if sys.platform != "win32" else None,
+ cffi_targets=( audioop syslog pwdgrp resource )
use gdbm && cffi_targets+=( gdbm )
use ncurses && cffi_targets+=( curses )
use sqlite && cffi_targets+=( sqlite3 )
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 73a3d5309d9c..1fd2d66ad5af 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -236,7 +236,8 @@ src_install() {
# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
- cffi_targets=( audioop syslog pwdgrp )
+# "resource": "_resource_build.py" if sys.platform != "win32" else None,
+ cffi_targets=( audioop syslog pwdgrp resource )
use gdbm && cffi_targets+=( gdbm )
use ncurses && cffi_targets+=( curses )
use sqlite && cffi_targets+=( sqlite3 )