summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-31 07:49:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-31 08:18:42 +0200
commit0c7cb11eb53e16ed2f567fb22c3a20d42fdf5d45 (patch)
tree89cd24e3112436cc11a7f5d777a034da6eadc780
parentdev-python/signature_dispatch: Enable py3.11 (diff)
downloadgentoo-0c7cb11e.tar.gz
gentoo-0c7cb11e.tar.bz2
gentoo-0c7cb11e.zip
dev-python/autoprop: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/autoprop/Manifest1
-rw-r--r--dev-python/autoprop/autoprop-4.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
index 4002b7bd201c..58f02c9cc9ea 100644
--- a/dev-python/autoprop/Manifest
+++ b/dev-python/autoprop/Manifest
@@ -1 +1,2 @@
DIST autoprop-4.0.2.tar.gz 20050 BLAKE2B 06165a02dfee0755ccf375041487f015e632b56b24766ac3d4bd484caaf1c99a0506994f16ace753f5890b782690b640196ee0cd6fcce0078ef51f8addcfcfe6 SHA512 27c8578e8f023715b07ebe21f4f46e98e606c863d3257bb1c8c31d9f59551d2494ef99e24eed856b308c8c77e1a3276f9e370434aa3e61ebb0b32a9b44fceee7
+DIST autoprop-4.1.0.tar.gz 20254 BLAKE2B 2229ac42ffaa8a874bc4ab8b0bd032b5898e4c93badfa8e8d7a6f93309cd6d922932e0c2a5753b048cf98caff802a9545a706a8d776a648af67cae95b42338f4 SHA512 be356ca41935d77719cfb51db397e48fca74663f00c65862cd0c776c9f5ac9f4af891951ae14a6006736493f3721dfc7edf195fe83e73ebfb486cd8f492bd778
diff --git a/dev-python/autoprop/autoprop-4.1.0.ebuild b/dev-python/autoprop/autoprop-4.1.0.ebuild
new file mode 100644
index 000000000000..c852a7266451
--- /dev/null
+++ b/dev-python/autoprop/autoprop-4.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/signature_dispatch-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest