summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2023-02-28 10:44:00 -0600
committerJoonas Niilola <juippis@gentoo.org>2023-03-09 08:50:23 +0200
commit0c83acf47fb5a28e736db9038b318d365afbe094 (patch)
tree4220072b88280caefd946a15954a07b80f01bf64
parentsys-process/wait_on_pid: update DESCRIPTION (diff)
downloadgentoo-0c83acf4.tar.gz
gentoo-0c83acf4.tar.bz2
gentoo-0c83acf4.zip
media-gfx/frogr: bump to 1.7, update 1.5's deps
Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Bug: https://bugs.gentoo.org/649234 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/frogr/Manifest1
-rw-r--r--media-gfx/frogr/frogr-1.5-r1.ebuild9
-rw-r--r--media-gfx/frogr/frogr-1.7.ebuild44
-rw-r--r--media-gfx/frogr/metadata.xml12
4 files changed, 61 insertions, 5 deletions
diff --git a/media-gfx/frogr/Manifest b/media-gfx/frogr/Manifest
index 1b660d38f522..df8a3b422b9b 100644
--- a/media-gfx/frogr/Manifest
+++ b/media-gfx/frogr/Manifest
@@ -1 +1,2 @@
DIST frogr-1.5.tar.xz 2233600 BLAKE2B aeb04db0d5d57f470d377986f2e857ee63b47df85e9c3251cdfac8585efa19491650ecede0bfa95c157c2584298dc02173afec624bc439dcd8b52d101c465d54 SHA512 f4af5ec82ad1771e71387c40467fc697c7e3edff9f76ecd0f762e446d136a293477867cb7b6bc6d10bc0fdd95210b25f515eb56bf2d456f79009884019c44dd4
+DIST frogr-1.7.tar.xz 2247476 BLAKE2B 16b5c546b61234310390f4dadee0094e671f141121023833123e57de7f90666a38a117dedece0cba53a1500e8bce20e79dd690c598e010327a32aee7b11afe1a SHA512 73531186dbe3fdb4b937d54c02b471b444bac059de4ea02913b5fef255816af0b0ef89bbb449e443ee5b50f0d156960efe190f5988a1a50f8ecfe2eb1e10b89f
diff --git a/media-gfx/frogr/frogr-1.5-r1.ebuild b/media-gfx/frogr/frogr-1.5-r1.ebuild
index 75bd15003391..212ea149f55c 100644
--- a/media-gfx/frogr/frogr-1.5-r1.ebuild
+++ b/media-gfx/frogr/frogr-1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,15 +15,16 @@ KEYWORDS="~amd64"
RDEPEND="
>=dev-libs/glib-2.44:2
>=dev-libs/json-glib-1.2
- >=x11-libs/gtk+-3.16:3[introspection]
- >=media-libs/libexif-0.6.14
+ >=dev-libs/libgcrypt-1.5:*
>=dev-libs/libxml2-2.6.8:2
media-libs/gstreamer:1.0
+ >=media-libs/libexif-0.6.14
>=net-libs/libsoup-2.34:2.4
- >=dev-libs/libgcrypt-1.5:*
+ >=x11-libs/gtk+-3.16:3[introspection]
"
DEPEND="${RDEPEND}"
BDEPEND="
+ dev-util/itstool
>=sys-devel/gettext-0.19.7
virtual/pkgconfig
"
diff --git a/media-gfx/frogr/frogr-1.7.ebuild b/media-gfx/frogr/frogr-1.7.ebuild
new file mode 100644
index 000000000000..06a0413faca2
--- /dev/null
+++ b/media-gfx/frogr/frogr-1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="flickr applications for GNOME"
+HOMEPAGE="https://live.gnome.org/Frogr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-1.2
+ >=dev-libs/libgcrypt-1.5:=
+ >=dev-libs/libxml2-2.6.8:2
+ media-libs/gstreamer:1.0
+ >=media-libs/libexif-0.6.14
+ >=net-libs/libsoup-2.34:2.4
+ >=x11-libs/gtk+-3.16:3[introspection]
+ x11-libs/gdk-pixbuf:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+# TODO add a useflag for enable-video or header-bar???
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/media-gfx/frogr/metadata.xml b/media-gfx/frogr/metadata.xml
index 1e1e3db44283..63a6a3cb5736 100644
--- a/media-gfx/frogr/metadata.xml
+++ b/media-gfx/frogr/metadata.xml
@@ -1,10 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
<longdescription>
Frogr is a small application for the GNOME desktop that allows users to
manage their accounts in the Flickr image hosting website. It supports all
the basic Flickr features.
</longdescription>
+ <maintainer type="person" proxied="yes">
+ <email>cfuga@cfuga.mx</email>
+ <name>Cristian Othón Martínez Vera</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/frogr</remote-id>
+ </upstream>
</pkgmetadata>