summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-09-12 11:13:18 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-09-12 11:13:18 +0200
commit0c844a6603dbd16e406cb4f9e97a30ca87d05209 (patch)
tree0108dff6b0c1d0ec53eed31dd6912c96433e9963
parentdev-python/mamba: Remove old (diff)
downloadgentoo-0c844a66.tar.gz
gentoo-0c844a66.tar.bz2
gentoo-0c844a66.zip
dev-ml/facile: VariableScope
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/facile/facile-1.1.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-ml/facile/facile-1.1.3.ebuild b/dev-ml/facile/facile-1.1.3.ebuild
index 06cb817ed4bc..2ae3f2c3be86 100644
--- a/dev-ml/facile/facile-1.1.3.ebuild
+++ b/dev-ml/facile/facile-1.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,8 +18,6 @@ DEPEND="${RDEPEND}
sys-apps/sed
"
-DOCS=( README )
-
PATCHES=( "${FILESDIR}/${PN}"-1.1-make.patch ) # Fix building on FreeBSD
src_prepare() {
@@ -35,11 +33,14 @@ src_prepare() {
-e 's:^.*facile\.cmxa::'\
-e 's:^.*facile\.a::' Makefile || die "failed to remove native code objects"
fi
+ sed -i \
+ -e 's|$(FACILE|$(DESTDIR)$(FACILE|g' \
+ Makefile || die
}
src_configure() {
# This is a custom configure script and it does not support standard options
- ./configure --faciledir "${D}"$(ocamlc -where)/facile/ || die
+ ./configure || die
}
src_test() {
@@ -48,6 +49,5 @@ src_test() {
src_install() {
dodir $(ocamlc -where)
- emake install
- einstalldocs
+ default
}