summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 16:12:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 16:16:16 +0200
commit0c8fa409c7a10c02652a274f3d53f2fc56a576e2 (patch)
tree95ebf3408605f422ce817b3cbd75ccb29047089e
parentsys-kernel/gentoo-kernel-bin: Bump to 5.8.4 (diff)
downloadgentoo-0c8fa409c7a10c02652a274f3d53f2fc56a576e2.tar.gz
gentoo-0c8fa409c7a10c02652a274f3d53f2fc56a576e2.tar.bz2
gentoo-0c8fa409c7a10c02652a274f3d53f2fc56a576e2.zip
app-portage/gemato: Bump to 15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-15.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 7b5b1603cf1b..59a690c51b70 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,3 +1,4 @@
DIST gemato-14.4.tar.gz 72630 BLAKE2B c8956b979d7c8629e245ba339e8ee707cd51ffe545a85c712c31b97ee2aaabef7a4964cac46c9cd8c4954c33529623293a94a26ae40b578a6b640aab15d47835 SHA512 0b514e4ff7773eefd2d9adc063a4fbc6a1e7d9ea3dfa783b1d5a8e6ec1e482533a8c70cd5e200a8b9671161d77e14254ad14aee6659e3c96eb9be3bbedcf11af
DIST gemato-14.5.tar.gz 72752 BLAKE2B 61ca43c92556850afdc8ab1d027aa719d13e77727caf9660d1861b1cb07ab40c05bd0fab23f99eaa47252e09465813685c59d1ebb5cc89c2c3381e1571256836 SHA512 0979de8cb4fc51c79d5af485092e0b376094238d6bb67d44db96c66b1d5ee945f0ba82dc6f72bea1042b935029cb790c5cd87bc419ba82da21a972141f3690bb
DIST gemato-15.0.tar.gz 73757 BLAKE2B 1315e621ccd10db4b1dea159fe01386e51632716b02dc1a5e797296b506de14506691b4cf9eeb58b66081ae761c1926c1c7fc6f1c1543143fb64e9e5dc47984e SHA512 ed88961bc22df77227c46ff013bafc801f1648827085bc02845b4374f3a4e67cdc79b68cb2bcd31956ac40cb0014e0f5348d79d77394ceed9152b2a0aa30599a
+DIST gemato-15.1.tar.gz 71954 BLAKE2B 29a899eb215b78c608f6846c8978837c96df5a69c112c771e4c25c89df268ef22e02bcfb171e9a1b5b2377af101c1029638156c7317e6961133b5a9206747204 SHA512 3263c8e0bc74e1b031775cc37697be5f3214d09ce00ea922af00b8b46638756ee74ad3bc75e73fe8e3563a0ccd5b76986a8f5fc7c00423db863296d89dd233a8
diff --git a/app-portage/gemato/gemato-15.1.ebuild b/app-portage/gemato/gemato-15.1.ebuild
new file mode 100644
index 000000000000..823a1340e968
--- /dev/null
+++ b/app-portage/gemato/gemato-15.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}