summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-02 09:31:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-02 09:31:12 +0100
commit0c950d4e36b28a09e055c33f511345cbf6e1c091 (patch)
tree8b7e975d7806ba37ce96671c166b6e6b99d7ec2d
parentdev-python/croniter: Bump to 1.0.6 (diff)
downloadgentoo-0c950d4e.tar.gz
gentoo-0c950d4e.tar.bz2
gentoo-0c950d4e.zip
dev-python/fastjsonschema: Bump to 2.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.15.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 8835172bcb41..8a68092dc88c 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST python-fastjsonschema-2.14.5.tar.gz 33488 BLAKE2B 4604ebd46851c8fe856909fa3943e053ac7359a9f360c189add2a46780fe045ca1952033174d008db7696bfc861a504c3aaa7389c33a2edbccd10cb14de8a097 SHA512 255db86d1d62845e512ca5669f3200360847d974710050ac53fe88536d6d9f943ccf41a8414702dad70fa1a38defe9859f2b608e13a54af11199c90d63cdf1d0
+DIST python-fastjsonschema-2.15.0.tar.gz 35225 BLAKE2B 43b5dce109b0b25db4906b13223ede61b9f9eee9acb05b207d3cd11e0cc1d3740674c4e29709ce55dca8b4964643942be0959267d0228a71ff8fb535ccc5de17 SHA512 3323c085e79e1a465e807ef972ecd3f09811e232a36abc16d6b2e3e2ac5cc343edf2610e18d18b64fdd555d640c0ef1dd3417e268b5c62738f82680a404a300a
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.15.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.15.0.ebuild
new file mode 100644
index 000000000000..3669e189ca8f
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.15.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="https://github.com/horejsek/python-fastjsonschema/"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}