summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 00:09:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 00:30:20 +0100
commit0c9b1aff14cdb086d09b3febbac6a6342f0586ed (patch)
treeff780b7b09981b8d71a9934806a125765a4b0be5
parentdev-python/testfixtures: Bump to 6.18.4 (diff)
downloadgentoo-0c9b1aff.tar.gz
gentoo-0c9b1aff.tar.bz2
gentoo-0c9b1aff.zip
dev-python/translate-toolkit: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.6.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index b95e4fff68d1..3aecc0b090eb 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1 +1,2 @@
DIST translate-3.5.3.gh.tar.gz 1148120 BLAKE2B e848a089281ab7f1e17b28beefbea50245025bc3db0616bab3f5e1d288b2aacc0df636dca11f17481af863a4845594ecff9fc66dbc33d403a8fe0575ff90581d SHA512 3ad1bc4742e4d91dbdd8b4662597d07c792e306426dac42b6f8720cefdf1f4cf502d587941df3e6a93dd5648a1b92f5951bd1b5e79a41e5476f1b9ca06624656
+DIST translate-3.6.0.gh.tar.gz 1150765 BLAKE2B 0b69d21782d8d6b3ae322b480ad2205e577d87a3a9448f8a428f666d3d141063ad06f83eaa38f5d5903cc4263bbdcf261523fef57111c1ba705b640835c11416 SHA512 3ce371cb688dcfa656676fdc3ca920d76088fad67dbfb112511a0439250913e1f4587df681752bf1b288b9c4af3e4ebd11b8f8db51670f0fe14e9db68d7917f7
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.6.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.6.0.ebuild
new file mode 100644
index 000000000000..c9ba581f8597
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.6.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="
+ https://github.com/translate/translate/archive/refs/tags/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+BDEPEND="
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${BDEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+BDEPEND+="
+ test? ( dev-python/phply[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-bootstrap-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/translate-toolkit-3.3.0-no-install-docs.patch
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}