summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2023-04-07 20:15:19 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2023-04-07 20:16:30 +0200
commit0cb75896d9acfea6936248b325e2c37914e92383 (patch)
treed8fc14603b80600b3f020acf67cd581d143a87d3
parentdev-ruby/arel-helpers: enable ruby31 (diff)
downloadgentoo-0cb75896.tar.gz
gentoo-0cb75896.tar.bz2
gentoo-0cb75896.zip
app-crypt/yubihsm-shell: do not run hw-dependent tests and sanitize cflags
Closes: https://bugs.gentoo.org/903983 Closes: https://bugs.gentoo.org/903984 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch20
-rw-r--r--app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild2
2 files changed, 22 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch b/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch
new file mode 100644
index 000000000000..633e5e05422d
--- /dev/null
+++ b/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch
@@ -0,0 +1,20 @@
+diff -ru yubihsm-shell-2.4.0-orig/cmake/SecurityFlags.cmake yubihsm-shell-2.4.0/cmake/SecurityFlags.cmake
+--- yubihsm-shell-2.4.0-orig/cmake/SecurityFlags.cmake 2023-04-07 20:11:44.438751635 +0200
++++ yubihsm-shell-2.4.0/cmake/SecurityFlags.cmake 2023-04-07 20:12:30.588873600 +0200
+@@ -4,7 +4,7 @@
+ CMAKE_C_COMPILER_ID STREQUAL "AppleClang" OR
+ CMAKE_C_COMPILER_ID STREQUAL "GNU")
+
+- add_compile_options (-Wall -Wextra -Werror)
++ add_compile_options (-Wall -Wextra)
+ add_compile_options (-Wformat -Wformat-nonliteral -Wformat-security)
+ add_compile_options (-Wshadow)
+ add_compile_options (-Wcast-qual)
+@@ -13,7 +13,6 @@
+ add_compile_options (-pedantic -pedantic-errors)
+ add_compile_options (-fpie -fpic)
+ if (NOT FUZZ)
+- add_compile_options(-O2)
+ add_definitions (-D_FORTIFY_SOURCE=2)
+ endif ()
+
diff --git a/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
index 6ff4ec262044..acc0bbc3eb7c 100644
--- a/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
+++ b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
@@ -8,10 +8,12 @@ inherit cmake
DESCRIPTION="Components used to interact with the YubiHSM 2"
HOMEPAGE="https://developers.yubico.com/yubihsm-shell/"
SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+PATCHES=( "${FILESDIR}"/${P}-remove-hardcoded-compiler-opts.patch )
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
+RESTRICT="test"
DEPEND="
dev-libs/openssl:=