summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-30 17:29:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-30 17:30:40 +0100
commit0cc8927af4397ecde0215fb4b37cb7108f594ca3 (patch)
tree0454fc19bd348f7f296584862da760b807e7fa6e
parentdev-ml/eliom: bump to 5.0.0 (diff)
downloadgentoo-0cc8927a.tar.gz
gentoo-0cc8927a.tar.bz2
gentoo-0cc8927a.zip
dev-ml/ppx_tools: bump to 0.99.3.
This version comes from a fork but opam (official ocaml PM) uses this, and eliom needs it. Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/ppx_tools/Manifest1
-rw-r--r--dev-ml/ppx_tools/ppx_tools-0.99.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools/Manifest b/dev-ml/ppx_tools/Manifest
index 0181b80fa80a..96063a15b71c 100644
--- a/dev-ml/ppx_tools/Manifest
+++ b/dev-ml/ppx_tools/Manifest
@@ -1 +1,2 @@
DIST ppx_tools_0.99.2.tar.gz 15877 SHA256 98128022ea0574d769a263eb9b73be06200eec4bac9adb8dc44df289a77c4dec SHA512 1ed8b3a670e233e77988d10c777003384c86c124b8b7e4cec41c0a3e0de280f818b7cbbddc59c49644517899ce0ef022407db6d4aaf29c559abc0788dce11594 WHIRLPOOL f04ecf57ab457ce2ea58b93a50215f49f257597ce4176a4cd3fe8ffb230ab1a898a479d2bbab3df2675b71f7123c556d3a7cd84e8b2263389ea02f3990585924
+DIST ppx_tools_0.99.3.tar.gz 16258 SHA256 79a9430086231e0a5a863f2aaebf3fb32f1ff0c25ab8cdfd11f53b4ce4550787 SHA512 2b6e4e1168951b5501e930e3de294611ed0652162b8e6a3e5b72d27d602ea4b3cf07bb96dc524347553c30be6d3a7ab5b28ef4d5d69e4de6f6c6e5359e37c32d WHIRLPOOL 0b38432072b25e4c6dafadd5aeac4e19680095c83c2be121f837caeeec8801aa077515e97b94e4c647f05640139d26b4cbfd69e796ba0027ce38009590b04a80
diff --git a/dev-ml/ppx_tools/ppx_tools-0.99.3.ebuild b/dev-ml/ppx_tools/ppx_tools-0.99.3.ebuild
new file mode 100644
index 000000000000..f31fbe735c03
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-0.99.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+# This is the version used by opam.
+# Needed by eliom-5[ppx]
+SRC_URI="http://github.com/diml/ppx_tools/archive/${PN}_${PV}.tar.gz"
+#SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${PN}_${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.02:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${PN}_${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}