summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 22:31:43 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 23:00:11 +0200
commit0cca1dbe3d74aa1f453b8779feb6d4a62d6f256e (patch)
treebeecb0a89612c741c51e5da99867e37f08c5e9b5
parentnet-nntp/inn: [QA] Add missing python metadata variables (diff)
downloadgentoo-0cca1dbe3d74aa1f453b8779feb6d4a62d6f256e.tar.gz
gentoo-0cca1dbe3d74aa1f453b8779feb6d4a62d6f256e.tar.bz2
gentoo-0cca1dbe3d74aa1f453b8779feb6d4a62d6f256e.zip
net-proxy/http-replicator: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-proxy/http-replicator/http-replicator-3.0-r7.ebuild13
-rw-r--r--net-proxy/http-replicator/http-replicator-4.0_alpha2-r5.ebuild10
2 files changed, 18 insertions, 5 deletions
diff --git a/net-proxy/http-replicator/http-replicator-3.0-r7.ebuild b/net-proxy/http-replicator/http-replicator-3.0-r7.ebuild
index 5b29f048344f..68405a1f8c1b 100644
--- a/net-proxy/http-replicator/http-replicator-3.0-r7.ebuild
+++ b/net-proxy/http-replicator/http-replicator-3.0-r7.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python2_7 ) # not 2.6 bug #33907, not 3.0 bug #411083
+
inherit eutils python-single-r1 systemd
MY_P="${PN}_${PV}"
@@ -10,11 +12,16 @@ MY_P="${PN}_${PV}"
DESCRIPTION="Proxy cache for Gentoo packages"
HOMEPAGE="https://sourceforge.net/projects/http-replicator"
SRC_URI="mirror://sourceforge/http-replicator/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ppc ~sparc x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/http-replicator-3.0-sighup.patch"
@@ -22,9 +29,11 @@ PATCHES=(
"${FILESDIR}/http-replicator-3-missing-directory.patch"
)
-src_install(){
+pkg_setup() {
python-single-r1_pkg_setup
+}
+src_install() {
# Daemon and repcacheman into /usr/bin
python_scriptinto /usr/bin
python_doscript http-replicator
diff --git a/net-proxy/http-replicator/http-replicator-4.0_alpha2-r5.ebuild b/net-proxy/http-replicator/http-replicator-4.0_alpha2-r5.ebuild
index 0eea7f1f1e73..6810108b67b9 100644
--- a/net-proxy/http-replicator/http-replicator-4.0_alpha2-r5.ebuild
+++ b/net-proxy/http-replicator/http-replicator-4.0_alpha2-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -16,6 +16,10 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -30,7 +34,7 @@ src_test() {
./unit-test && die
}
-src_install(){
+src_install() {
python_foreach_impl python_doscript http-replicator
newbin "${FILESDIR}"/${PN}-3.0-callrepcacheman-0.1 repcacheman