summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-30 08:35:10 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-30 08:59:56 +0100
commit0ced8d67bbc57ee3eb40a8cf1aeacdaa27086d72 (patch)
tree784b76ca045258612cf644c7cdf072430bdb8520
parentversion bump (diff)
downloadgentoo-0ced8d67.tar.gz
gentoo-0ced8d67.tar.bz2
gentoo-0ced8d67.zip
dev-python/setuptools: FVersion Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-18.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 641eae082996..4273d9797c9c 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-18.4.tar.gz 626632 SHA256 cdea5098e60b4ad83453d58723a61dc481ca8e2df251fe4ccbea9afa5a7d111f SHA512 f45f0bdec365642d1648c502a964bafeb518e8f0ed63091a50b278629cf1e17df7f66769b0ddaab1e7c5ae2574673435ccab72886a2d5eb311eaac451c485854 WHIRLPOOL e0c5d69f57ce234b0e002a50c882df0bf1e908224c045baa8b5a62e91148d654f048cfbb64375b59f61f0845a5e850ec03594606933fdfaa9cce9b357bb45aa7
DIST setuptools-18.5.tar.gz 626892 SHA256 4846755f18c0528d87583342d5e1221052858ce9922c5c38acbadd5015bd683d SHA512 d902b7e35c99d21e243168072bc96c07f88a7463e50035ba72d7e10818777e83ce534e4dab2ae0425620791f95f3d8cb2f9d9142be1ea24f05100d85d0d44835 WHIRLPOOL f3cabbc4bda9964bc00eba392e04605c99c1927fa96482ac55e21b1af7271b8a1c102017dea0b615ab02ca0f7219d9a8eab3b83eef6895d8b35f6bcbe4ed7747
DIST setuptools-18.6.1.tar.gz 627042 SHA256 ddb0f4bdd1ac0ceb41abfe561d6196a840abb76371551dbf0c3e59d8d5cde99a SHA512 50752fc55fe70c1fe7c84d27d6dd046da376e0656c957e36709923ed129dcecf09637e35d64cc677d1e75612b2fc53f3213c97e8bed816dff5248085756a1882 WHIRLPOOL b6ba95bd18db05867a94b756ab1ec71a0861096ffa8ae9bf2dd1410e1465df71a10e52af527b5f72bd685da5ccbfa795b6e1855a0d11aa54e8f28287fa54236e
+DIST setuptools-18.7.tar.gz 628702 SHA256 c57c1f5aa3b83e4c5e0ce5b144a7f96eea1dab873f35d5aaa3c2a2d960674353 SHA512 7e00cd0148aee0435e571347db1d2dae9fa194fe3bdd5d1fc561bb353ce4272869355a5e8f9a1ed99136df43f9d7848d57d2cd46c920040673bfdc05e189d050 WHIRLPOOL c50e83fb91ed7cd08e9f3538fb8425adcc1d5eb3a8be072914e73d2e765888f71c6fd891c821c96c21ad24728f7381c5b5a4b01c23887550877a0931b5ad7d86
diff --git a/dev-python/setuptools/setuptools-18.7.ebuild b/dev-python/setuptools/setuptools-18.7.ebuild
new file mode 100644
index 000000000000..713d1deca53f
--- /dev/null
+++ b/dev-python/setuptools/setuptools-18.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-python/packaging-15.3-r1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}