summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-31 23:11:56 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-31 23:12:49 -0400
commit0d00adc28b71485d559d107d981aeb881937f5ca (patch)
treeb057a22240d0a417ca159f78b23fc8d97b247a51
parentnet-misc/ofono: version bump (diff)
downloadgentoo-0d00adc2.tar.gz
gentoo-0d00adc2.tar.bz2
gentoo-0d00adc2.zip
dev-python/pychroot: version bump to 0.9.16
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.9.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 097197f454f8..898a45da918b 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1,2 +1,3 @@
DIST pychroot-0.9.13.tar.gz 25610 SHA256 e94c9c738402f4957e757aa1fdcd2febeaa7cc01df1b1ca0d6adf3324a8bbfce SHA512 ec2773e9285905aa1fc83a69653e830fc83c42c306760bbc9a8bf48cd388b99485a7ec30eef32ef4cc98cf25fe12b9ac1d09ae379c25d4c756d3afbffdfc2243 WHIRLPOOL bff205fb563e7e3f9603a639310cbf24ec10234e96e813082aeec94bc5cb3155947f818f53713a09f0626e5dad21a4d0b4c1c49d26eeb894677872e30bef92b7
DIST pychroot-0.9.15.tar.gz 29519 SHA256 3215f650b05dc78d26233df0f8a62befe5eb9998e207023909cc098b8fd8f623 SHA512 7764a7853f81f438c652bc37d135a0938ab9bbb4ec7d4a344e6e4613b1ec85a5da33da52f4ac5945ebc9da81263858cb3797f43af52811b86fa70601274ce3de WHIRLPOOL 2695c8c01c81c86d966afb476fa25f770a84ae5a56636fa326a771982f5467494acae2932fefd71cf3e79639e490596b7914ab2ae56642675bb121d9b1aa8a7c
+DIST pychroot-0.9.16.tar.gz 31027 SHA256 8bcfde4f045d34181ab6ec869abb6608c1340de4dd15ceac003287ec610d221d SHA512 6e35c7b40ad27d234c855abf1857aa6579583d848b111559de21edfa0bc6987e08d1d122924101e2e9bdf37886591b7291a607ed22cf2c50aa11b32f7ea65495 WHIRLPOOL 234cdd15e1cda4473d061ec03f8be75560785ca53c441750372d34545e6e0a1d068a2bf9f652cc60486793fb294d3af1d68834602ab0e0160e4194a2a0f6a98d
diff --git a/dev-python/pychroot/pychroot-0.9.16.ebuild b/dev-python/pychroot/pychroot-0.9.16.ebuild
new file mode 100644
index 000000000000..a38d17e16bee
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/snakeoil-0.7.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ distutils-r1_python_install install_man
+ distutils-r1_python_install_all
+}