summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-21 09:00:59 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-21 09:23:38 -0500
commit0d0c0152a108ab4123bba310eea13e8e6559349c (patch)
tree22ded9c2ec45016d4682d75902e03aee0c7a6c91
parentprofiles/arm64/musl: enable openjdk:17 bootstrap using our xpak (diff)
downloadgentoo-0d0c0152.tar.gz
gentoo-0d0c0152.tar.bz2
gentoo-0d0c0152.zip
net-misc/ytfzf: add 2.1
Use Makefile given upstream added necessary variables, removed gzip, and made it usable. Drop chafa optfeature, support isn't gone but it's just one of many non-default options that all have drawbacks for wayland. Trying to display them all would just be noise, and users should preferably look at ytfzf's documentation for ueberzug alternatives. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 23b6d80b921d..1ce75414567e 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.0.tar.gz 3227372 BLAKE2B fa67fdc44174e1a0bbbf581f51fc0010230a6de37a38f54bd6c3b5dc1a8ae19790486db90ab0ab1f15fa1a70b544dd7888ec88c6f53ec5c2543235f64dc1ab94 SHA512 43c43b6a446335a7eef9d206864069df1e075d49151b359ead47de6e7234efc1042ce0557233e53c303d3c38572fd33a955e229c457561211250ddd0df5ccb0e
+DIST ytfzf-2.1.tar.gz 3230643 BLAKE2B b296048c976c260b3192f770bdf2dec99f5ad45066deeac23429808254552ea125ea8a8d129c47a5110916c4194f7b7742dd01f095809f4913077600a8205d4b SHA512 a86203bc1dffd05ff3543c44d5612bc8b0ffc675ce0484499cb89aa88c2618c88e832dd95ff2cd6f1803698c1c3264709a1e280ddbb9fb0985c0178f3adc16ea
diff --git a/net-misc/ytfzf/ytfzf-2.1.ebuild b/net-misc/ytfzf/ytfzf-2.1.ebuild
new file mode 100644
index 000000000000..c11320bd52ab
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv/yt-dlp "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box while allowing to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ virtual/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "in-terminal thumbnails on X11" media-gfx/ueberzug
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 2.0; then
+ elog "Note that >=${PN}-2.0 is a major rewrite and is not compatible with"
+ elog "configuration and some command arguments of older versions, see the"
+ elog "newly added ${PN}(1) and ${PN}(5) man pages for more information."
+ fi
+}