summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-08 10:58:07 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-08 11:38:56 +0200
commit0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa (patch)
tree360ad694062f4670a7b113f8631048f263fb3dbb
parentsci-libs/libcifpp: add 5.1.0 (diff)
downloadgentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.tar.gz
gentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.tar.bz2
gentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.zip
sci-chemistry/dssp: add 4.3.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.3.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index a0bf5ede05c2..00d6647cdc54 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -1,3 +1,4 @@
DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1bc820a0df0db6a5f78ac0229aafdd47a60b8fd6f4832abf0399663c53f9e898c75f08ecbe22b141c8da SHA512 4a273714d6b3230daea166caa7f4117d5ccb225bea0cf1bc2eb61539b6cc8e227d0ba19047d61f0ad0d1d6bc2efdec9c193bd44341e15ef0950acb4a22498811
DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a67737a3485dcbd160d1597a15c2d5105c3794c875d8001abede1c014efb4f7f5b7c250f867bdf9ed95a0860217 SHA512 a0cfe44e517ff1f909ef2928b62ae2c639c6bddfd8a0fb538883f647fd2771e00da68e0fd2521aa02ba3c6d1b0c9b784b7fe142392af3a3abf6ea89f1546bd9d
DIST dssp-4.2.2.1.tar.gz 144413 BLAKE2B 97c587bc0b4ef3d212ae81d568f817aab54f1dd2a77d170746e9b0d3f1bd63873d21fb0a7fc38c0300fc091f21241820d5d009d42a9e3e33dcc608c046185d9f SHA512 6daa41aea766940bf40afaee068daef341a7f79cae79d967b8da00e7002bdb602deaed40e452a5f0cea9aa2041a5c8678dfcae2e0f595cc5a0856392162dcdff
+DIST dssp-4.3.1.tar.gz 226842 BLAKE2B 86318f05b8381d94fa9c65a956f5fb607ef8072b0395d912e20697ba36836c449ddff31a4a64d0005bbfe34899f71853c0f15a911042389fc894934c08fc34c8 SHA512 4dc1a3f5c7ba258ebf548674c7b33c36b0e3a7d14911394eb8d2955c235f3cb1d6c50cb03f411db55a8a9d7aa93e4d03354c47f9f0126b0bdcbf40dc9391d403
diff --git a/sci-chemistry/dssp/dssp-4.3.1.ebuild b/sci-chemistry/dssp/dssp-4.3.1.ebuild
new file mode 100644
index 000000000000..daf7c4f9314d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-5.1.0
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+src_configure() {
+ # gxrio not packaged
+ local mycmakeargs=(
+ -DBUILD_WEBSERVER=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}