summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 22:30:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 22:50:36 +0100
commit0d1d7cb8ea81f8a0dd0eb347d3f814b7e8fa6dd5 (patch)
tree7428abc92d142e8d4a5f3ff8ad93be41ea7ab603
parentdev-util/pkgcheck: Bump to 0.9.1 (diff)
downloadgentoo-0d1d7cb8.tar.gz
gentoo-0d1d7cb8.tar.bz2
gentoo-0d1d7cb8.zip
dev-python/reportlab: Bump to 3.5.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.63.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 36c3384c2c77..7982cd956812 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-3.5.60.tar.gz 2905122 BLAKE2B 8863e910dac03d5fd1d53880bb9fe83d218641156e481c97b498e462cf9e1e5c6826f2f25fcef7c65cee3dbc7551401bfd1dba6a319532363b7c9cbc9c37e618 SHA512 395ad0c904215ba3ae16efa52140b7cc6f751efd04c70f687a8891806b346d78c75bb29df5aa0d6d49adb6f5638da58704e713ee1500df05424c9dddc38afad2
+DIST reportlab-3.5.63.tar.gz 2908785 BLAKE2B 0af6f72063e4a1f4464bf8d847575e23b5d96ced3bdbafa518e56503194e98aed5e07c17fbf6cf07d3d95ef91b3d0d450233024b40368889dc1ef5d8792050fe SHA512 39c940a585695752095b868fa631396193083d9d270512e0e89e766e02d749745b6d0438f2d9f5ec2ea58c7da6aa538a0315fbd7483571ebc2c460035e12a1bf
diff --git a/dev-python/reportlab/reportlab-3.5.63.ebuild b/dev-python/reportlab/reportlab-3.5.63.ebuild
new file mode 100644
index 000000000000..71dd8dad099d
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.63.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests unittest
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ mydistutilsargs=(
+ --no-download-t1-files
+ --use-system-libart
+ )
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}