summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-10-31 09:40:19 -0400
committerKenton Groombridge <concord@gentoo.org>2022-10-31 09:41:10 -0400
commit0d2de82efb7e1a2de3df481f889102f82fa728b4 (patch)
tree08ddf49b24bd043db99839076a3a1d687a6b077a
parentwww-apps/miniflux: drop 2.0.37 (diff)
downloadgentoo-0d2de82e.tar.gz
gentoo-0d2de82e.tar.bz2
gentoo-0d2de82e.zip
www-apps/miniflux: fix variable quoting
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
-rw-r--r--www-apps/miniflux/miniflux-2.0.38.ebuild2
-rw-r--r--www-apps/miniflux/miniflux-2.0.39.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/www-apps/miniflux/miniflux-2.0.38.ebuild b/www-apps/miniflux/miniflux-2.0.38.ebuild
index 4ef790cbc12c..e13b13d7f56d 100644
--- a/www-apps/miniflux/miniflux-2.0.38.ebuild
+++ b/www-apps/miniflux/miniflux-2.0.38.ebuild
@@ -88,7 +88,7 @@ pkg_config() {
# Extract the database URL variable instead of just sourcing the config file
# because miniflux itself may interpret quotes as part of the URL
- local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' ${EROOT}/etc/${PN}.conf)"
+ local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' "${EROOT}/etc/${PN}.conf")"
[[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate || die "miniflux -migrate failed. Please check the above output for errors."
diff --git a/www-apps/miniflux/miniflux-2.0.39.ebuild b/www-apps/miniflux/miniflux-2.0.39.ebuild
index 4ef790cbc12c..e13b13d7f56d 100644
--- a/www-apps/miniflux/miniflux-2.0.39.ebuild
+++ b/www-apps/miniflux/miniflux-2.0.39.ebuild
@@ -88,7 +88,7 @@ pkg_config() {
# Extract the database URL variable instead of just sourcing the config file
# because miniflux itself may interpret quotes as part of the URL
- local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' ${EROOT}/etc/${PN}.conf)"
+ local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' "${EROOT}/etc/${PN}.conf")"
[[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate || die "miniflux -migrate failed. Please check the above output for errors."