summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-25 21:55:42 -0400
committerSam James <sam@gentoo.org>2023-10-27 03:29:20 +0100
commit0d2f6fde905d8976293470a06c033410b6c6edd0 (patch)
tree0ffc9ed7e672ef21e2c185306f41350e140bf578
parentdev-python/oslo-config: remove incorrect rdepend on importlib-metadata (diff)
downloadgentoo-0d2f6fde905d8976293470a06c033410b6c6edd0.tar.gz
gentoo-0d2f6fde905d8976293470a06c033410b6c6edd0.tar.bz2
gentoo-0d2f6fde905d8976293470a06c033410b6c6edd0.zip
dev-python/sphinxcontrib-bibtex: remove incorrect rdepend
importlib-metadata, specifically. The original implementation of importlib-metadata in sphinxcontrib-bibtex used the stdlib importlib.metadata, for python >=3.10. https://github.com/mcmtroffaes/sphinxcontrib-bibtex/commit/051973a987236f04aeb0902d6c9011ec6e108103 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33519 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..3e70af03cf4d
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/sphinxcontrib-bibtex/
+ https://pypi.org/project/sphinxcontrib-bibtex/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-docutils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # rinoh not packaged
+ test/test_citation_rinoh.py::test_citation_rinoh
+ test/test_citation_rinoh.py::test_citation_rinoh_multidoc
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ epytest
+}