summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-31 06:38:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-31 06:38:29 +0100
commit0d328b1a4e4780a717b2c6027be4db56882209db (patch)
treeaa2508d00f86efacdc7d93d81f0064245cea67e0
parentdev-python/jc: add 1.22.4 (diff)
downloadgentoo-0d328b1a.tar.gz
gentoo-0d328b1a.tar.bz2
gentoo-0d328b1a.zip
dev-python/botocore: Bump to 1.29.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.41.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 818c9f53dfa4..932f57bad609 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,3 +9,4 @@ DIST botocore-1.29.37.gh.tar.gz 11077206 BLAKE2B 59c877edba074d4d5858dbf0a4026c0
DIST botocore-1.29.38.gh.tar.gz 11079677 BLAKE2B 3edca40f575278b24c4b65ccaba3432715f8d7908f6e561cc475963f0865ef777a53845a1e8579f023a4943d69f33c8e1071afa6dd214d480dd48bacc8c132e1 SHA512 814863a6653f36f58bb20d4c7e154ba6d731f4046f3183ce696f515b1baa5ce342620bdfdd09eeea3847c6494add5611651487ad4d8f9c773823cf20393cb940
DIST botocore-1.29.39.gh.tar.gz 11079996 BLAKE2B 5354766665b3402861cd497ee2831cb82c7d6db977c6573cb43cd70ec06291a4eba6c39a601c798414c2fb47c92f14df6e302623c1d5a5523edfdd9c977bf579 SHA512 bf7c30313737792eea1506855aa166cac63fcba48b764ec5e5b2313c9c66fe48970cfeef1f7405f329db715ee0b9d49ff4550d6d69ccd4c7db09923e77bcbe8d
DIST botocore-1.29.40.gh.tar.gz 11081508 BLAKE2B f303b055083d41646367ed8d1c72cbb51cd229d5a2e5268265e90ed9ddb1fe99bc314b1ca5ed44e537b4056e7f2cf14acf610e2d2b448419b7b735e26c57f81d SHA512 ad8c90fd4a6de0ef28bd48a870a5918ad12cc842b7c5abbc1fdd77a1a0dc9231f40ef76eab5f367009bb590437e2c109d40883cec2af961f379345d5da89b761
+DIST botocore-1.29.41.gh.tar.gz 11082628 BLAKE2B a42a66299715159e82bb7bd9ceb5d1d60e88bfe2f59f66231605c909b03110ec18e6f946690c5b33e662fc92719e45fa4cf64ac31176d809908f3574fece5d49 SHA512 b3a5409f3d868c93fd038687d8c864be3c9cacbf4740ba0dd745358cadcce9aa8d76616d7f93316ac14f5f94f18ed42505ec108e2557b234b26c01ca0f3fc22c
diff --git a/dev-python/botocore/botocore-1.29.41.ebuild b/dev-python/botocore/botocore-1.29.41.ebuild
new file mode 100644
index 000000000000..36f6e1eb862b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.41.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}