summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:44:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:43 +0100
commit0d37fe3a319ece0f50af0999c01568d6a659558a (patch)
tree8053cb694d2a2f1962473e05aea922d5bcca7fd3
parentdev-python/django-cors-headers: Remove old (diff)
downloadgentoo-0d37fe3a.tar.gz
gentoo-0d37fe3a.tar.bz2
gentoo-0d37fe3a.zip
dev-python/django-cors-headers: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.10.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.10.1-r1.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.10.1-r1.ebuild
new file mode 100644
index 000000000000..2c4e48a4ed9f
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.10.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="https://github.com/adamchainz/django-cors-headers"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest