summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-08-03 07:34:34 +0200
committerHans de Graaff <graaff@gentoo.org>2022-08-03 07:34:34 +0200
commit0d481c9866229db290f6dd54851b1fb64ab846cf (patch)
treef75c8d58813fa9671debee55da45d5ca9430b57c
parentdev-ruby/hiera: add 3.10.0 (diff)
downloadgentoo-0d481c9866229db290f6dd54851b1fb64ab846cf.tar.gz
gentoo-0d481c9866229db290f6dd54851b1fb64ab846cf.tar.bz2
gentoo-0d481c9866229db290f6dd54851b1fb64ab846cf.zip
dev-ruby/http-accept: add 2.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/http-accept/Manifest1
-rw-r--r--dev-ruby/http-accept/http-accept-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/http-accept/Manifest b/dev-ruby/http-accept/Manifest
index 7f5c799b9ab7..8b388a3912df 100644
--- a/dev-ruby/http-accept/Manifest
+++ b/dev-ruby/http-accept/Manifest
@@ -1,2 +1,3 @@
DIST http-accept-1.7.0.tar.gz 12289 BLAKE2B 5eda9bd29e2dd2b52c8f2589adf57872a80aaf93c37d28b1668dc24fc1e2fa81d00ec12766dd558691dbf3e6560bba013f456a659ead47fffd77b1565c186a7f SHA512 3502bfbd07f6bb0164843c728cd5ef27adfd675317fd60372539180de212d02d6d446cff8eb081d1cbe5a19b30d5759a55b22bc63736cea83254595bd691522f
DIST http-accept-2.1.1.tar.gz 12488 BLAKE2B b909736c0fda14b32f30c38f12f4c4c2b2bf1a36ddf753069484b6b7151d518b80a6ae8dba929e27f8f758c0c0ae0c52c24802f02b1bfd4674ca33b50d7a0de0 SHA512 e0231cae90ce9180006714485df2cf205bf1f114887dc581ea50fb558c1c7e434838d10d0c9f69c1d747249b8d0c73e628a6ea7b1ffa1ffa7059ba2447307df2
+DIST http-accept-2.2.0.tar.gz 14174 BLAKE2B b6fd0c065a1d9c798ebee8a2f82aa45738cf98721d42d9806614fd98c8ce5d571ce06ad3292e81a972e484f55c75c0e99c5ad54f138323b180bb9292f87b3049 SHA512 341b09b3f8ba132ba9394c904bbe7c95a91fe0b39b080ae96d8228b8474f2d7de6edf4d9dce0b16783ac12aa375b0cda99be67290656f3348219f52d66b7f120
diff --git a/dev-ruby/http-accept/http-accept-2.2.0.ebuild b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
new file mode 100644
index 000000000000..4cfb7baa55fc
--- /dev/null
+++ b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="http-accept.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse Accept and Accept-Language HTTP headers"
+HOMEPAGE="https://github.com/socketry/http-accept"
+SRC_URI="https://github.com/socketry/http-accept/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+ sed -e 's:_relative ": "./:' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}