summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-06 09:10:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-06 09:44:21 +0200
commit0d61d354bc8a71946ec1b2f63d4e8177cd2ddbe8 (patch)
tree2d59cb0e78452d464f0793a7e14352de8665bce1
parentdev-python/shiboken2: adjust clang header finding logic for clang>=16 (diff)
downloadgentoo-0d61d354bc8a71946ec1b2f63d4e8177cd2ddbe8.tar.gz
gentoo-0d61d354bc8a71946ec1b2f63d4e8177cd2ddbe8.tar.bz2
gentoo-0d61d354bc8a71946ec1b2f63d4e8177cd2ddbe8.zip
app-text/liblangtag: drop 0.6.3
Bug: https://bugs.gentoo.org/744688 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/liblangtag/Manifest1
-rw-r--r--app-text/liblangtag/files/liblangtag-0.6.3-fix-for-gtk-doc-1.32.patch28
-rw-r--r--app-text/liblangtag/liblangtag-0.6.3.ebuild60
3 files changed, 0 insertions, 89 deletions
diff --git a/app-text/liblangtag/Manifest b/app-text/liblangtag/Manifest
index 807aa173a3e3..debe6fb1f71c 100644
--- a/app-text/liblangtag/Manifest
+++ b/app-text/liblangtag/Manifest
@@ -1,2 +1 @@
-DIST liblangtag-0.6.3.tar.bz2 755492 BLAKE2B fb7b3cf5a4e6c3fabdce110ab208fa9e3537d8144839f2fc9779ff9de928afa416838c5c3c5317438ae0421806eb6ffb2207f6ad3dc02bcbf9123668187d22d2 SHA512 3dcfc20704dfaff05aeecdeef74fa81639fb70f930ebc0895fe4707ecd1d5b6221fe889449772811924d0c38329977c9d5fc751c3accbc272834b29c461f1fcf
DIST liblangtag-0.6.4.tar.bz2 764946 BLAKE2B 1d94f341359f880acb8a0a0526da625cb39d85b33665b861c0fbd94064228a3d5328f3a3b7d62bffd29c6ff8161fa499b6565010ba3065c90f87b5902969e81f SHA512 6c6dd3e6b0fc8d6f10cafd74112cbaf2a2342a88a908ad2f7ae759b3f5fb0cf6d788504c1de072e9ef019f2f5a284daeb2d2393036b6b402c5bc87f32b55f271
diff --git a/app-text/liblangtag/files/liblangtag-0.6.3-fix-for-gtk-doc-1.32.patch b/app-text/liblangtag/files/liblangtag-0.6.3-fix-for-gtk-doc-1.32.patch
deleted file mode 100644
index 86d7a651bbb9..000000000000
--- a/app-text/liblangtag/files/liblangtag-0.6.3-fix-for-gtk-doc-1.32.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Fix build with gtk-doc-1.32
-
-This bug was reported here:
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939956
-
-The issue is that gtk-doc-1.32 no longer generates empty tree_index
-files. The recommendation is that liblangtag be modified to no longer
-reference what used to be an empty tree_index, but is now a missing
-file. The same bug report contained the patch implemented here, which
-removes the reference to a now-missing tree_index file.
-
-The fix should already be provided in newer versions of liblangtag.
-
-diff --git a/docs/liblangtag-docs.sgml b/docs/liblangtag-docs.sgml
-index 1234567..1234567 100644
---- a/docs/liblangtag-docs.sgml
-+++ b/docs/liblangtag-docs.sgml
-@@ -58,10 +58,6 @@
- </section>
-
- </chapter>
-- <chapter id="object-tree">
-- <title>Object Hierarchy</title>
-- <xi:include href="xml/tree_index.sgml"/>
-- </chapter>
- <index id="api-index-full">
- <title>API Index</title>
- <xi:include href="xml/api-index-full.xml"><xi:fallback /></xi:include>
diff --git a/app-text/liblangtag/liblangtag-0.6.3.ebuild b/app-text/liblangtag/liblangtag-0.6.3.ebuild
deleted file mode 100644
index 78e75c1e5a1b..000000000000
--- a/app-text/liblangtag/liblangtag-0.6.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit xdg-utils
-
-DESCRIPTION="An interface library to access tags for identifying languages"
-HOMEPAGE="https://bitbucket.org/tagoh/liblangtag/wiki/Home"
-SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
-
-LICENSE="|| ( LGPL-3 MPL-2.0 )"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86"
-IUSE="debug doc introspection static-libs test"
-
-BDEPEND="
- sys-devel/gettext
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- introspection? ( dev-libs/gobject-introspection-common )
-"
-RDEPEND="
- dev-libs/libxml2
- introspection? ( dev-libs/gobject-introspection )
-"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
-"
-
-# Upstream expect liblangtag to be installed when one runs tests...
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-for-gtk-doc-1.32.patch"
-)
-
-src_prepare() {
- default
- xdg_environment_reset
- if [[ -d docs/html ]]; then
- rm -r docs/html || die "Failed to remove existing gtk-doc"
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable doc gtk-doc)
- $(use_enable introspection)
- $(use_enable static-libs static)
- $(use_enable test)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}