summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-24 14:55:48 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-24 15:00:16 -0700
commit0d66666dae215a18ffcd888fa962deed19f68e34 (patch)
treec8524a945ef476932105e54d842476697bced808
parentmedia-libs/glu: Port to Meson (diff)
downloadgentoo-0d66666dae215a18ffcd888fa962deed19f68e34.tar.gz
gentoo-0d66666dae215a18ffcd888fa962deed19f68e34.tar.bz2
gentoo-0d66666dae215a18ffcd888fa962deed19f68e34.zip
media-libs/glu: Version bump to 9.0.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/glu/Manifest1
-rw-r--r--media-libs/glu/glu-9.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/glu/Manifest b/media-libs/glu/Manifest
index 5550e23795e8..4ed45bc45d22 100644
--- a/media-libs/glu/Manifest
+++ b/media-libs/glu/Manifest
@@ -1 +1,2 @@
DIST glu-9.0.1.tar.xz 434632 BLAKE2B ed624b107a97ac84517cd0fa740090746ab93c77498135bf6dae3ee488e04afc93b0d239aba15533de8ab407d3d3d5e7cb5086b29985d93037e78753b249741e SHA512 8a6dae5b4bd63efb96d15f23ccda4ad9c2ffaa964897e5fa63d1e58360d8d4e6732c5efd2109dba04155d5fc457ab1718a65cf9b544ce0d452679ba988d04018
+DIST glu-9.0.2.tar.xz 436176 BLAKE2B 90485938e4809ce7bb56da25bd60be9f3f7b7f40d511ea6635e40d749e519d1dca6241d891224d3cf331b911f545df4ef9aa2101baf4e3b18df69244edbcb8a4 SHA512 2517d7406bb643d12c017a95dcb5d8716f307344332638bcbdf274a90752a7c22165d34745f1b082ed916bb07d40e62d1d1d67d96426225be63166f3480d6f64
diff --git a/media-libs/glu/glu-9.0.2.ebuild b/media-libs/glu/glu-9.0.2.ebuild
new file mode 100644
index 000000000000..978531ce2bb7
--- /dev/null
+++ b/media-libs/glu/glu-9.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit meson-multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dgl_provider=glvnd
+ )
+ meson_src_configure
+}